<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-8&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-8&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-8&cb=5', false, [], true, false, true, false);</script>

<meta name="description" content="To help keep meetings safe, and productive, and to reduce disruptions, Google is adding the ability to let Workspace for Education customers delegate tasks to up to 25 co-hosts!"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
<title>Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos</title>
<meta name="robots" content="max-image-preview:large"/>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="TxKFgqoM9wSS_5tNVu2Tfyy2LhgsK5yFVEZXV80wICU"/>
<link rel="amphtml" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet?amp"/><meta name="generator" content="AMP for WP 1.0.77.19"/><link rel="dns-prefetch" href="//code.ionicframework.com"/>
<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News » Feed" href="https://chromeunboxed.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News » Comments Feed" href="https://chromeunboxed.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News » Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos Comments Feed" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet/feed/"/>
<link rel="canonical" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/chromeunboxed.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="no-sidebar-pro-css" href="https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/style.css?ver=1.0.215" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-block-library-css" href="https://chromeunboxed.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8" type="text/css" media="all"/>
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" href="https://chromeunboxed.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-mediaelement-css" href="https://chromeunboxed.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8" type="text/css" media="all"/>
<style id="dcl-front-style-dummy-inline-css" type="text/css">
#dcl_btn_container{text-align: center;margin-top:10px;margin-bottom:10px}
</style>
<link rel="stylesheet" id="patreon-wordpress-css-css" href="https://chromeunboxed.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.8" type="text/css" media="all"/>
<link rel="stylesheet" id="ionicons-css" href="//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css?ver=1.0.215" type="text/css" media="all"/>
<link rel="stylesheet" id="social-logos-css" href="https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.0" type="text/css" media="all"/>
<link rel="stylesheet" id="jetpack_css-css" href="https://chromeunboxed.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.0" type="text/css" media="all"/>
<script type="text/javascript" src="https://chromeunboxed.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<!-- OG: 2.9.2 -->
<meta property="og:image" content="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg"/><meta property="og:image:secure_url" content="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg"/><meta property="og:image:width" content="1920"/><meta property="og:image:height" content="1080"/><meta property="og:image:alt" content="Google Meet Bulk Knock Feature"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:description" content="To help keep meetings safe, and productive, and to reduce disruptions, Google is adding the ability to let Workspace for Education customers delegate tasks to up to 25 co-hosts! These co-hosts will have direct access to the same controls as the primary host - muting participants, launching polls, and managing Q&amp;As on your behalf so..."/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Chrome Unboxed - The Latest Chrome OS News"/><meta property="og:title" content="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos"/><meta property="og:url" content="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet"/><meta property="og:updated_time" content="2021-08-13T11:12:00-04:00"/><meta property="article:published_time" content="2021-08-13T15:11:32+00:00"/><meta property="article:modified_time" content="2021-08-13T15:12:00+00:00"/><meta property="article:author" content="https://chromeunboxed.com/author/michael/"/><meta property="article:section" content="Apps"/><meta property="article:section" content="Education"/><meta property="article:section" content="Enterprise"/><meta property="article:section" content="New &amp; Upcoming Features"/><meta property="article:section" content="News"/><meta property="article:section" content="Updates"/><meta property="twitter:partner" content="ogwp"/><meta property="twitter:card" content="summary_large_image"/><meta property="twitter:title" content="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos"/><meta property="twitter:description" content="To help keep meetings safe, and productive, and to reduce disruptions, Google is adding the ability to let Workspace for Education customers delegate tasks to up to 25 co-hosts! These co-hosts will have direct access to the same controls as the primary host - muting participants, launching polls,..."/><meta property="twitter:url" content="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet"/><meta property="twitter:image" content="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg"/><meta property="profile:first_name" content="Michael"/><meta property="profile:last_name" content="Perrigo"/><meta property="profile:username" content="Michael Perrigo"/><!-- /OG -->
<link rel="https://api.w.org/" href="https://chromeunboxed.com/wp-json/"/><link rel="alternate" type="application/json" href="https://chromeunboxed.com/wp-json/wp/v2/posts/50297"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chromeunboxed.com/xmlrpc.php?rsd"/>
<link rel="alternate" type="application/json+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fworkspace-for-education-25-co-hosts-google-meet"/>
<link rel="alternate" type="text/xml+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fworkspace-for-education-25-co-hosts-google-meet&amp;format=xml"/>
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://chromeunboxed.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://chromeunboxed.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style><style type="text/css">img#wpstats{display:none}</style>
		<meta name="google-site-verification" content="heKdKP4cn3F3o5Bpy6diX_5mqJ7DSwReinb7QNQ6AE8"/>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78354183-1', 'auto');
  ga('send', 'pageview');

</script>

<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"/>
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/>
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/>
<link rel="manifest" href="/site.webmanifest"/>
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5"/>
<meta name="msapplication-TileColor" content="#2b5797"/>
<meta name="theme-color" content="#ffffff"/>
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-3946689793100734",
enable_page_level_ads: true,
tag_partner: "genesis"
});
</script>


<meta name="ir-site-verification-token" value="211200374"/>

<meta name="facebook-domain-verification" content="gi350v6cc8x05iypdkmaflqw4h9o4s"/><style type="text/css">.site-title a { background: url(https://chromeunboxed.com/wp-content/uploads/2019/01/cropped-newCUlogo-2.png) no-repeat !important; }</style>
<!-- AB7CD46E-101E-4A29-A3E6-33E72A51FB43 -->
<meta name="theme-color" content="#FFFFFF"/>

<!-- Schema & Structured Data For WP v1.9.83 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article"/>
<meta property="og:title" content="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos"/>
<meta property="og:url" content="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet"/>
<meta property="og:description" content="To help keep meetings safe, and productive, and to reduce disruptions, Google is adding the ability to let Workspace for Education customers delegate tasks to up to 25 co-hosts! These co-hosts will…"/>
<meta property="article:published_time" content="2021-08-13T15:11:32+00:00"/>
<meta property="article:modified_time" content="2021-08-13T15:12:00+00:00"/>
<meta property="og:site_name" content="Chrome Unboxed - The Latest Chrome OS News"/>
<meta property="og:image" content="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg"/>
<meta property="og:image:width" content="1920"/>
<meta property="og:image:height" content="1080"/>
<meta property="og:locale" content="en_US"/>
<meta name="twitter:site" content="@chromeunboxed"/>
<meta name="twitter:text:title" content="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos"/>
<meta name="twitter:image" content="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg?w=640"/>
<meta name="twitter:card" content="summary_large_image"/>

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-180x180.png"/>
<meta name="msapplication-TileImage" content="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-270x270.png"/>
<script type="text/javascript">var ezouid = "1";</script><base href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 75190;
var ezdomain = 'chromeunboxed.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":75190,"domain_test_group":20210304,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"26726219-9b3f-47b4-759d-70be9fe535fd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":56472,"response_time_orig":8,"serverid":"3.236.228.21:28876","state":"VA","t_epoch":1628872867,"template_id":126,"time_on_site_visit":0,"url":"https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet","user_id":0,"word_count":734,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_75190=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["26726219-9b3f-47b4-759d-70be9fe535fd", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-50297 single-format-standard custom-header header-image header-full-width full-width-content genesis-breadcrumbs-visible" itemscope="" itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li></ul><div class="topSpace">

<!-- <a href="https://chromeunboxed.com/chrome-unboxed-100000-youtube-subscriber-giveaway-pixel-chromebook-flip-c434/" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/02/onTheRun100KHeader2.jpg" class="desktopHeader"></a>

<a href="https://chromeunboxed.com/chrome-unboxed-100000-youtube-subscriber-giveaway-pixel-chromebook-flip-c434/" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/02/onTheRun100KHeaderMobile.jpg" class="mobileHeader"></a>

<a href="https://fave.co/2QQx9iN" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/03/BHphotoBannerHeaderFinal.jpg" class="desktopHeader"></a>

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120"><img src="https://chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020mobileFull70off-3.jpg" class="mobileHeader"></a>

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120"><img src="https://chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020mobileFull70off-3.jpg" class="mobileHeader"></a>

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020Full70off-3.jpg" class="desktopHeader"></a>

<a href="https://fave.co/3jy5YEV" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/11/SamsungCyberWeekHeader.png" class="desktopHeader"></a>

-->

<a href="https://patreon.com/chromeunboxed/" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/08/patreonHeader3.jpg" class="desktopHeader"/></a>

</div><div class="code-block code-block-9" style="margin: -2px auto -2px; text-align: center; display: block; clear: both; height: auto !important;">
<div class="desktopHeaderBanner">
<!-- Ezoic - AMP top of page - top_of_page -->
			<div id="ezoic-pub-ad-placeholder-669">
				<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
				<!-- In Content Ad -->
				<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
				<script>
				     (adsbygoogle = window.adsbygoogle || []).push({});
				</script>
				</div>
			<!-- End Ezoic - AMP top of page - top_of_page -->
</div></div>
<header class="site-header" itemscope="" itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://chromeunboxed.com/">Chrome Unboxed - The Latest Chrome OS News</a></p><p class="site-description" itemprop="description">A Space for All Things Chrome, Google, and More!</p></div><nav class="nav-primary" aria-label="Main" itemscope="" itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-primary-navigation-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3111"><a href="https://chromeunboxed.com/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-2877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2877"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-5765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5765"><a href="https://chromeunboxed.com/unboxing/" itemprop="url"><span itemprop="name">Unboxing</span></a></li>
<li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2873"><a href="https://chromeunboxed.com/chromebooks/" itemprop="url"><span itemprop="name">Chromebooks</span></a></li>
<li id="menu-item-5764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5764"><a href="https://chromeunboxed.com/upcoming-devices/" itemprop="url"><span itemprop="name">Upcoming</span></a></li>
<li id="menu-item-8136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8136"><a href="https://chromeunboxed.com/deals/" itemprop="url"><span itemprop="name">Deals</span></a></li>
<li id="menu-item-2878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2878"><a href="https://chromeunboxed.com/tips-tricks/" itemprop="url"><span itemprop="name">Tips</span></a></li>
<li id="menu-item-8361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8361"><a href="https://chromeunboxed.com/podcast/" itemprop="url"><span itemprop="name">Podcast</span></a></li>
<li id="menu-item-27826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27826"><a href="https://chromeunboxed.com/smart-home/" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-27823" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27823"><a href="https://chromeunboxed.com/gaming/" itemprop="url"><span itemprop="name">Gaming</span></a></li>
<li id="menu-item-5766" class="keepForMobile menu-item menu-item-type-post_type menu-item-object-page menu-item-5766"><a href="https://chromeunboxed.com/search-chrome-unboxed/" itemprop="url"><span itemprop="name">SEARCH</span></a></li>
</ul></div></nav><form class="search-form" method="get" action="https://chromeunboxed.com/" role="search" itemprop="potentialAction" itemscope="" itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search" itemprop="query-input"/><input class="search-form-submit" type="submit" value="Search"/><meta content="https://chromeunboxed.com/?s={s}" itemprop="target"/></form></div></header><div class="sideBarHolder-1">
    <div class="sideBar"><!-- Ezoic - sidebar_floating_1 - sidebar_floating_1 -->
<div id="ezoic-pub-ad-placeholder-672"><script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<!-- End Ezoic - sidebar_floating_1 - sidebar_floating_1 --></div>
</div>

<div class="sideBarHolder-2">
    <div class="sideBar"><!-- Ezoic - sidebar_floating_1 - sidebar_floating_1 -->
<div id="ezoic-pub-ad-placeholder-672"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<!-- End Ezoic - sidebar_floating_1 - sidebar_floating_1 --></div>
</div><div class="site-inner"><div class="content-sidebar-wrap"><!-- Ezoic - New-CU-Top - top_of_page -->
<div id="ezoic-pub-ad-placeholder-123">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</div>
<!-- End Ezoic - New-CU-Top - top_of_page --><main class="content" id="genesis-content"><div class="breadcrumb" itemscope="" itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://chromeunboxed.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"/></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://chromeunboxed.com/apps/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Apps</span></a><meta itemprop="position" content="2"/></span> <span aria-label="breadcrumb separator">/</span> Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos</div><article class="post-50297 post type-post status-publish format-standard has-post-thumbnail category-apps category-education category-enterprise category-new-upcoming-features category-news category-updates entry" aria-label="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos" itemscope="" itemtype="https://schema.org/CreativeWork"><div class="featured-image"><img src="https://chromeunboxed.com/wp-content/uploads/2020/11/Google-Meet-Bulk-Knock-Feature.jpg" alt="Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos"/></div><header class="entry-header"><h1 class="entry-title" itemprop="headline">Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos</h1>
<img alt="" src="https://secure.gravatar.com/avatar/5c5e9a40a44b57c66443188cb7c045fd?s=96&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/5c5e9a40a44b57c66443188cb7c045fd?s=192&amp;d=mm&amp;r=g 2x" class="avatar avatar-96 photo" height="96" width="96" loading="lazy"/><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-08-13T11:11:32-04:00">August 13, 2021</time> By <span class="entry-author" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><a href="https://chromeunboxed.com/author/michael/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Michael Perrigo</span></a></span> <span class="entry-comments-link"><a href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet#disqus_thread"><span class="dsq-postid" data-dsqidentifier="50297 https://chromeunboxed.com/?p=50297">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text"><div class="wp-remixd-voice-wrapper"><script type="text/javascript" id="remixd-audio-player-script" src="https://tags.remixd.com/player/v5/index.js?cb=%%CACHEBUSTER%%" charset="utf-8" async=""></script></div>
<p>To help keep meetings safe, and productive, and to reduce disruptions, Google is adding the ability to let Workspace for Education customers delegate tasks to up to 25 co-hosts! These co-hosts will have direct access to the same controls as the primary host – muting participants, launching polls, and managing Q&amp;As on your behalf so that you can lead the discussion without having to be directly responsible for all of the smaller nuances of a meeting.</p>



<p>Additional hosts will also be able to use Meet’s new safety features to limit who can perform screen shares, send chat messages, and more – even down to muting all users and ending meetings with a single click. Additionally, the ‘Quick access’ menu will allow all who are sharing control to let participants into the meeting and control who else may become a co-host.</p><div class="code-block code-block-1" style="margin: 0px auto 20px; text-align: center; display: block; clear: both;">
<div id="ezoic-pub-ad-placeholder-127">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>




<div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://1.bp.blogspot.com/-mVZvl9c5Uhg/YRRfVSccPmI/AAAAAAAAKIs/jcV_MPYzrKg4AIt--IxXZiyRRTFoMs2lQCLcBGAsYHQ/s512/host2.gif" alt=""/></figure></div>



<p>To get started, all you’ll need to do as the core host is to check the Meet ‘Host controls’ settings and make certain that ‘Host management’ is turned on. In the coming weeks, Workspace console admins will be able to control this setting right from their dashboard outside of meetings as well. As a quick aside, if you have ‘Quick access’ disabled, no anonymous users will be able to join the meeting, only the host will be able to dial out, the host must join the meeting first, and only invited participants can join without asking first.</p>



<p>Google is rolling out another useful feature with this update as well. You can now search for meeting participants in the People panel instead of having to manually scroll through them all in order to locate someone. With the popularity of Meet on the rise and with it being used practically everywhere, meeting sizes have certainly increased, so this is a welcome addition! The following users will be able to do all of this and more on the Web, Android, and iOS over the next two weeks beginning on August 16, 2021. Depending on how Google rolls it out, you may see these features any day now!</p><div class="code-block code-block-2" style="margin: 0px auto 20px; text-align: center; display: block; clear: both;">
<div id="ezoic-pub-ad-placeholder-126">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>



<div class="crp_related crp_related_block  "><h5>more from Chrome Unboxed</h5><ul><li><a href="https://chromeunboxed.com/zoom-meetings-private-security-zoombombing-passwords-2fa/" target="_blank" class="crp_link post-16465"><figure><img loading="lazy" width="150" height="150" src="https://chromeunboxed.com/wp-content/uploads/2020/03/protect-your-zoom-event-150x150.png" class="crp_thumb crp_featured" alt="Zoom users take heed to prevent uninvited guests in your meeting rooms" title="Zoom users take heed to prevent uninvited guests in your meeting rooms"/></figure><span class="crp_title">Zoom users take heed to prevent uninvited guests in your meeting rooms</span></a><span class="crp_author">  by <a href="https://chromeunboxed.com/author/gabe/">Gabriel Brangers</a></span> </li></ul><div class="crp_clear"></div></div>


<blockquote class="wp-block-quote"><p>All Workspace customers<br/>G Suite Basic<br/>G Suite for Business</p><cite>Quick Access settings availability</cite></blockquote>



<blockquote class="wp-block-quote"><p>Workspace Essentials<br/>Enterprise Essentials<br/>Enterprise Standard<br/>Enterprise Plus<br/>Business Standard<br/>Business Plus<br/>Education Fundamentals<br/>Education Standard<br/>Education Plus<br/>Teaching and Learning Upgrade</p><cite>Adding Co-Hosts availability</cite></blockquote>



<a href="https://patreon.com/chromeunboxed/" target="_blank" rel="noopener"><img src="https://chromeunboxed.com/wp-content/uploads/2021/03/AdFreeChromeUnboxed.png" class="patreonDesktop"/></a>



<div class="newsletterSignupBlock">
	Get Alerted About New Posts On <br class="forMobileOnly"/><span class="highlighter">Your Schedule</span><br/>
	<a class="BuyButton" href="https://chromeunboxed.com/newsletter-sign-up/" target="_blank" rel="noopener">Sign Up For The Official Chrome Unboxed Newsletter</a>
<div class="divider"></div>
<h6>Latest Posts</h6>
<div class="wp-rss-template-container" data-wpra-template="default" data-template-ctx="eyJmZWVkcyI6Im5ld2VzdHBvc3RzIn0=">
    <div class="wp-rss-aggregator wpra-list-template  " data-page="1">
    
    
<ul class="wpra-item-list rss-aggregator " start="1">
                        <li class="wpra-item feed-item gurss">
            
            

    <a href="https://chromeunboxed.com/samsung-galaxy-z-flip3-5g-first-foldable-on-google-fi/" target="_blank" rel="nofollow" class="">The Samsung Galaxy Z Flip3 5G is the first foldable on Google Fi</a>






<div class="wprss-feed-meta">
    
    
    </div>





            
        </li>
                    <li class="wpra-item feed-item gurss">
            
            

    <a href="https://chromeunboxed.com/android-games-chrome-os-chromebook-keyboard-mouse-mapping-compatibility" target="_blank" rel="nofollow" class="">Android games on non-touch Chromebooks may get a keyboard and mouse workaround</a>






<div class="wprss-feed-meta">
    
    
    </div>





            
        </li>
                    <li class="wpra-item feed-item gurss">
            
            

    <a href="https://chromeunboxed.com/wasserstein-made-for-google-accessories-nest-cam-doorbell" target="_blank" rel="nofollow" class="">Wasserstein launches its new Made for Google Nest Cam and Doorbell (battery) accessories</a>






<div class="wprss-feed-meta">
    
    
    </div>





            
        </li>
                    <li class="wpra-item feed-item gurss">
            
            

    <a href="https://chromeunboxed.com/alder-lake-chromebooks-12th-gen-intel" target="_blank" rel="nofollow" class="">As 11th-gen Intel Chromebooks hit their stride, more 12th-gen devices hit development</a>






<div class="wprss-feed-meta">
    
    
    </div>





            
        </li>
        </ul>

        
</div>

</div>

</div>



<a href="https://chromeunboxed.com/chrome-unboxed-giveaway-200000-youtube-subscribers" target="_blank" rel="noopener"><img src="https://chromeunboxed.com/wp-content/uploads/2021/04/ontheRunto200KGiveaway-1024x640.jpg" style="border-radius: 10px; padding: 15px; border: 2px solid #ddd;" alt=""/></a>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener" data-shared="sharing-twitter-50297" class="share-twitter sd-button share-icon no-text" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener" data-shared="sharing-facebook-50297" class="share-facebook sd-button share-icon no-text" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://chromeunboxed.com/workspace-for-education-25-co-hosts-google-meet?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://chromeunboxed.com/apps/" rel="category tag">Apps</a>, <a href="https://chromeunboxed.com/education/" rel="category tag">Education</a>, <a href="https://chromeunboxed.com/enterprise/" rel="category tag">Enterprise</a>, <a href="https://chromeunboxed.com/new-upcoming-features/" rel="category tag">New &amp; Upcoming Features</a>, <a href="https://chromeunboxed.com/news/" rel="category tag">News</a>, <a href="https://chromeunboxed.com/updates/" rel="category tag">Updates</a></span> </p></footer></article><section class="author-box" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><img alt="" src="https://secure.gravatar.com/avatar/5c5e9a40a44b57c66443188cb7c045fd?s=160&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/5c5e9a40a44b57c66443188cb7c045fd?s=320&amp;d=mm&amp;r=g 2x" class="avatar avatar-160 photo" height="160" width="160" loading="lazy"/><h4 class="author-box-title">About <span itemprop="name">Michael Perrigo</span></h4><div class="author-box-content" itemprop="description"><p>Think. Tinker. Dominate. Game developer and author. Must learn something new every day. I have a passion for the mobile games industry and where it&#39;s headed. I enjoy working out and eating delicious food to counteract my progress.</p>
</div></section><div id="disqus_thread">
				<div id="dcl_btn_container">
			<button id="dcl_comment_btn" class="">
				Load Comments			</button>
		</div>
	</div>
</main></div></div><footer class="site-footer" itemscope="" itemtype="https://schema.org/WPFooter"><div class="wrap"><p class="socialLinks"><a href="https://twitter.com/chromeunboxed" target="_blank">TWITTER</a> | <a href="https://www.facebook.com/Chromeunboxed/" target="_blank">FACEBOOK</a> | <a href="https://instagram.com/chromeunboxed/" target="_blank">INSTAGRAM</a> | <a href="https://www.youtube.com/channel/UCkHgegL2XiXSlwY5zeCKKyg" target="_blank">YOUTUBE</a> | <a href="mailto:info@chromeunboxed.com" target="_blank">EMAIL</a> | <a href="https://chromeunboxed.com/about/" target="_blank">ABOUT</a> </p>
<div class="divider"></div>
<p>Copyright © 2021 · Chrome Unboxed · <a href="http://google.com">Chrome is a registered trademark of Google Inc.</a><br/><em>We are participants in various affiliate advertising programs designed to provide a means for us to earn fees by linking to affiliated sites.</em></p>
<p><a href="/newsletter-sign-up/" class="footerButton">GET EMAIL UPDATES</a></p>
<p><a class="footerButton" href="https://g.ezoic.net/privacy/chromeunboxed.com" target="_blank">Privacy Policy</a></p><nav class="nav-secondary" aria-label="Secondary" itemscope="" itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav-2" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-864"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287"><a href="https://chromeunboxed.com/editorial/" itemprop="url"><span itemprop="name">Editorial</span></a></li>
<li id="menu-item-285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-285"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
</ul></div></nav></div></footer></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-EN8kTmgFbx_41"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-EN8kTmgFbx_41.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chromeunboxed.com\/workspace-for-education-25-co-hosts-google-meet":50297};
	</script>
				<link rel="stylesheet" id="colorbox-css" href="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/css/colorbox.css?ver=1.4.33" type="text/css" media="all"/>
<link rel="stylesheet" id="wpra-list-template-styles-css" href="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/css/templates/list/styles.css?ver=4.19" type="text/css" media="all"/>
<link rel="stylesheet" id="wpra-pagination-css" href="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/css/build/pagination.min.css?ver=4.19" type="text/css" media="all"/>
<script type="text/javascript" id="dcl_comments-js-extra">
/* <![CDATA[ */
var countVars = {"disqusShortname":"chrome-unboxed"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"50297 https:\/\/chromeunboxed.com\/?p=50297","disqusShortname":"chrome-unboxed","disqusTitle":"Google Meet hosts can now add up to 25 co-hosts at a time to help them manage the chaos","disqusUrl":"https:\/\/chromeunboxed.com\/workspace-for-education-25-co-hosts-google-meet","postId":"50297"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/disqus-conditional-load/assets/js/embed-click.min.js?ver=11.0.6" id="dcl_comments-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.8" id="patreon-wordpress-js-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1" id="hoverIntent-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10" id="superfish-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.5" id="superfish-args-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.5" id="skip-links-js"></script>
<script type="text/javascript" id="ns-responsive-menu-js-extra">
/* <![CDATA[ */
var NoSidebarL10n = {"mainMenu":"Menu","subMenu":"Menu"};
/* ]]> */
</script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/responsive-menu.js?ver=1.0.0" id="ns-responsive-menu-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/search-box.js?ver=1.0.0" id="ns-search-box-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-includes/js/wp-embed.min.js?ver=5.8" id="wp-embed-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/js/jquery.colorbox-min.js?ver=5.8" id="jquery.colorbox-min-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/js/custom.js?ver=5.8" id="wprss_custom-js"></script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/js/build/wpra-manifest.min.js?ver=4.19" id="wpra-manifest-js"></script>
<script type="text/javascript" id="wpra-pagination-js-extra">
/* <![CDATA[ */
var WpraPagination = {"baseUri":"https:\/\/chromeunboxed.com\/wp-json\/wpra\/v1\/templates\/%s\/render\/"};
/* ]]> */
</script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/wp-rss-aggregator/js/build/pagination.min.js?ver=4.19" id="wpra-pagination-js"></script>
<script type="text/javascript" id="sharing-js-js-extra">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.0" id="sharing-js-js"></script>
<script type="text/javascript" id="sharing-js-js-after">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script src="https://stats.wp.com/e-202132.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'112270166',post:'50297',tz:'-4',srv:'chromeunboxed.com'} ]);
	_stq.push([ 'clickTrackerInit', '112270166', '50297' ]);
</script>
<!--[selectrongo:video:done]--><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=8&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=8&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="chromeunboxed_com",_audins_did=75190;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-8");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.chromeunboxed_com,DomainId.75190" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=8&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>