<!DOCTYPE html>
<html lang="en-US" id="arve">
<head >
<meta charset="UTF-8" />
<meta name="description" content="Just in case you haven’t been around the Chrome Unboxed site lately or Chromebook news in general, let me catch you up to speed on what could be one of the biggest developments ever to come to the Chrome OS ecosystem. The average user has been using a container on Chrome OS for some time now and may be completely unaware. Android apps on a Chromebook run in their very own containers. ARC (Android Runtime for Chrome) isolates Android apps inside Linux containers to sandbox them and maintain the integrity of the Chrome operating system." />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Visual Studio Code Spotted Running On Pixelbook Via Crostini Container</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Feed" href="https://chromeunboxed.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Comments Feed" href="https://chromeunboxed.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Visual Studio Code Spotted Running On Pixelbook Via Crostini Container Comments Feed" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/feed/" />
<link rel="canonical" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/chromeunboxed.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='milan-pro-css'  href='https://chromeunboxed.com/wp-content/themes/milan-pro/style.css?ver=1.1.38' type='text/css' media='all' />
<style id='milan-pro-inline-css' type='text/css'>

		.site-header,
		.single .entry-title:before,
		.comment-reply-title  {
			background-color: #777777;
		}

		.archive-pagination a,
		.site-main #infinite-handle span button,
		.site-main #infinite-handle span button:hover,
		.site-main #infinite-handle span button:focus,
		.archive-pagination a:before,
		#infinite-handle button:before,
		.main-navigation a,
		.byline a,
		.cat-links a,
		.entry-content a,
		.featured-primary .entry-excerpt a,
		.post-navigation .nav-links a,
		.comment-navigation a,
		.comment-content a,
		.comment-form a,
		.comment-author span[itemprop="name"] a,
		.widget a,
		.site-footer p a,
		.breadcrumb a,
		.featured-row {
			border-color: #777777;
		}
		

		.site-header {
			background-image: url( '' );
		}
</style>
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.1.38' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='https://chromeunboxed.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://chromeunboxed.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.8.27'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/advanced-ads-pro/modules/click-fraud-protection/assets/js/cfp.min.js?ver=2.1.2'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=4.9.4'></script>
<script type='text/javascript'>
(adsbygoogle = window.adsbygoogle || []).push({google_ad_client: "ca-pub-3946689793100734", enable_page_level_ads: true, tag_partner: "genesis"});
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/milan-pro/js/main.js?ver=1.1.38'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='https://chromeunboxed.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chromeunboxed.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fnews%2Fchrome-os-container-crostini-vscode-virtual-machine" />
<link rel="alternate" type="text/xml+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fnews%2Fchrome-os-container-crostini-vscode-virtual-machine&#038;format=xml" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78354183-1', 'auto');
  ga('send', 'pageview');

</script>

<meta name="google-site-verification" content="heKdKP4cn3F3o5Bpy6diX_5mqJ7DSwReinb7QNQ6AE8" /><!-- AB7CD46E-101E-4A29-A3E6-33E72A51FB43 --><style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #cccccc !important; border-radius: 0px; color: #aaaaaa !important; border: 0px #ffffff solid !important; font-size: 30px; padding: 15px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #eeeeee !important; border-color: #ffffff !important; color: #34a853 !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #eeeeee !important; }</style>	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<link rel="amphtml" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Visual Studio Code Spotted Running On Pixelbook Via Crostini Container" />
<meta property="og:url" content="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine" />
<meta property="og:description" content="Just in case you haven&#8217;t been around the Chrome Unboxed site lately or Chromebook news in general, let me catch you up to speed on what could be one of the biggest developments ever to come t…" />
<meta property="article:published_time" content="2018-03-24T21:44:23+00:00" />
<meta property="article:modified_time" content="2018-03-24T23:37:44+00:00" />
<meta property="og:site_name" content="Chrome Unboxed - The Latest Chrome OS News" />
<meta property="og:image" content="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=1200%2C854&amp;ssl=1" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="854" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Visual Studio Code Spotted Running On Pixelbook Via Crostini Container" />
<meta name="twitter:image" content="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=1200%2C854&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
		<script data-cfasync="false" type="text/javascript">
			var __ATA_PP = { pt: 1, ht: 2, tn: 'milan-pro', amp: false };
			var __ATA = __ATA || {};
			__ATA.cmd = __ATA.cmd || [];
			__ATA.criteo = __ATA.criteo || {};
			__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>		<link rel='dns-prefetch' href='//s.pubmine.com' />
		<link rel='dns-prefetch' href='//x.bidswitch.net' />
		<link rel='dns-prefetch' href='//static.criteo.net' />
		<link rel='dns-prefetch' href='//ib.adnxs.com' />
		<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
		<link rel='dns-prefetch' href='//bidder.criteo.com' />
		<link rel='dns-prefetch' href='//cas.criteo.com' />
		<link rel='dns-prefetch' href='//gum.criteo.com' />
		<link rel='dns-prefetch' href='//ads.pubmatic.com' />
		<link rel='dns-prefetch' href='//gads.pubmatic.com' />
		<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
		<link rel='dns-prefetch' href='//ad.doubleclick.net' />
		<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
		<link rel='dns-prefetch' href='//www.googletagservices.com' />
		<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
		<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
		<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
		<script data-cfasync="false" async type="text/javascript" src="//s.pubmine.com/head.js"></script><link rel="icon" href="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon.png?fit=270%2C270&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-5070 single-format-standard wp-custom-logo custom-header header-full-width full-width-content" itemscope itemtype="https://schema.org/WebPage"><div class="headMenu">
<a href="/news/">News</a><a href="/upcoming-devices/">Upcoming</a><a href="/reviews/">Reviews</a><a href="/unboxing/">Unboxing</a><a href="/tips-tricks/">Tips & Tricks</a><a href="/apps/">Apps</a><a href="/chromebooks/">Chromebooks</a><a href="/chromecast/">Chromecast</a><a href="/google-assistant/">Google Assistant</a><a href="/deals/">Deals</a><a href="/about/">About</a>
</div><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://chromeunboxed.com/">Chrome Unboxed - The Latest Chrome OS News</a></p><p class="site-description" itemprop="description">A Space for All Things Chrome</p></div><div class="customHeader"><a href="https://chromeunboxed.com/" rel=”nofollow”><img src="/wp-content/uploads/2017/06/ChromeUnboxedLogoDarker.png"></a></div>
<div class="bannerAdOne">
  <div class="adHolder">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- New Responsive Header Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="9597230804"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
  </div>
</div>	<button id="menu-toggle" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"><span class="screen-reader-text">Primary Navigation Menu</span></button>
</div></header>	<div id="slide-menu" class="slide-menu">
		<a href="https://chromeunboxed.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="2500" height="2500" src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" class="custom-logo" alt="Chrome Unboxed &#8211; The Latest Chrome OS News" itemprop="logo" data-attachment-id="2968" data-permalink="https://chromeunboxed.com/cropped-cuemenulogo-png/" data-orig-file="https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?fit=2500%2C2500&amp;ssl=1" data-orig-size="2500,2500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-cueMenuLogo.png" data-image-description="&lt;p&gt;http://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png&lt;/p&gt;
" data-medium-file="https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?fit=1024%2C1024&amp;ssl=1" data-lazy-src="https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?fit=2500%2C2500&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?w=2500&amp;ssl=1 2500w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?resize=1024%2C1024&amp;ssl=1 1024w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?resize=350%2C350&amp;ssl=1 350w, https://i0.wp.com/chromeunboxed.com/wp-content/uploads/2017/06/cropped-cueMenuLogo.png?w=2000 2000w" data-lazy-sizes="(max-width: 2500px) 100vw, 2500px" /></a>		<nav id="site-navigation" class="main-navigation" role="navigation">
			<div class="menu-primary-navigation-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3111"><a href="https://chromeunboxed.com/news/" itemprop="url">News</a></li>
<li id="menu-item-2880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2880"><a href="https://chromeunboxed.com/upcoming-devices/" itemprop="url">Upcoming Devices</a></li>
<li id="menu-item-2877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2877"><a href="https://chromeunboxed.com/reviews/" itemprop="url">Reviews</a></li>
<li id="menu-item-2879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2879"><a href="https://chromeunboxed.com/unboxing/" itemprop="url">Unboxing</a></li>
<li id="menu-item-2870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2870"><a href="https://chromeunboxed.com/apps/" itemprop="url">Apps</a></li>
<li id="menu-item-2878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2878"><a href="https://chromeunboxed.com/tips-tricks/" itemprop="url">Tips &#038; Tricks</a></li>
<li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2873"><a href="https://chromeunboxed.com/chromebooks/" itemprop="url">Chromebooks</a></li>
<li id="menu-item-2874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2874"><a href="https://chromeunboxed.com/chromecast/" itemprop="url">Chromecast</a></li>
<li id="menu-item-3092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3092"><a href="https://chromeunboxed.com/google-assistant/" itemprop="url">Google Assistant</a></li>
<li id="menu-item-2872" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2872"><a href="https://chromeunboxed.com/chrome-os/" itemprop="url">Chrome OS</a></li>
<li id="menu-item-2871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2871"><a href="https://chromeunboxed.com/chrome/" itemprop="url">Chrome</a></li>
<li id="menu-item-2875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2875"><a href="https://chromeunboxed.com/deals/" itemprop="url">Deals</a></li>
<li id="menu-item-2876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2876"><a href="https://chromeunboxed.com/editorial/" itemprop="url">Editorial</a></li>
<li id="menu-item-2881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2881"><a href="https://chromeunboxed.com/about/" itemprop="url">About Chrome Unboxed</a></li>
</ul></div>		</nav><!-- #site-navigation -->
	</div><!-- #slide-menu -->
<div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-5070 post type-post status-publish format-standard has-post-thumbnail category-chrome-os category-news category-pixelbook category-preview entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Visual Studio Code Spotted Running On Pixelbook Via Crostini Container</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-03-24T17:44:23+00:00">March 24, 2018</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://chromeunboxed.com/author/gabe/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gabriel Brangers</span></a></span> <span class="entry-comments-link"><a href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine#respond"><span class="dsq-postid" data-dsqidentifier="5070 http://chromeunboxed.com/?p=5070">Leave a Comment</span></a></span> </p></header><div class="entry-wrap"><div class="entry-meta"><div class="post-author"><img alt src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" class="avatar avatar-70 photo" height="70" width="70" data-lazy-src="https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=70&#038;d=mm&#038;r=g" data-lazy-srcset="https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=140&#038;d=mm&#038;r=g 2x"><noscript><img alt='' src='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></noscript><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://chromeunboxed.com/author/gabe/">Gabriel Brangers</a></span></span></div><span class="posted-on"><a href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine" rel="bookmark"><time class="entry-date published" datetime="2018-03-24T17:44:23+00:00">March 24, 2018</time><time class="updated" datetime="2018-03-24T19:37:44+00:00">March 24, 2018</time></a></span><span class="cat-links"><span class="cats-title">Filed under:</span><ul class="post-categories">
	<li><a href="https://chromeunboxed.com/chrome-os/" rel="category tag">Chrome OS</a></li>
	<li><a href="https://chromeunboxed.com/news/" rel="category tag">News</a></li>
	<li><a href="https://chromeunboxed.com/pixelbook/" rel="category tag">Pixelbook</a></li>
	<li><a href="https://chromeunboxed.com/preview/" rel="category tag">Preview</a></li></ul></span></div><div class="entry-content" itemprop="text"><p><img data-attachment-id="5071" data-permalink="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/vscode/" data-orig-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=2432%2C1730&amp;ssl=1" data-orig-size="2432,1730" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vscode" data-image-description data-medium-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=300%2C213&amp;ssl=1" data-large-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=1024%2C728&amp;ssl=1" class="aligncenter size-large wp-image-5071" src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" alt width="1024" height="728" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=1024%2C728" data-lazy-srcset="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=1024%2C728&amp;ssl=1 1024w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=300%2C213&amp;ssl=1 300w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=768%2C546&amp;ssl=1 768w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?w=2000 2000w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img data-attachment-id="5071" data-permalink="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/vscode/" data-orig-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=2432%2C1730&amp;ssl=1" data-orig-size="2432,1730" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vscode" data-image-description="" data-medium-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=300%2C213&amp;ssl=1" data-large-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?fit=1024%2C728&amp;ssl=1" class="aligncenter size-large wp-image-5071" src="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=1024%2C728" alt="" width="1024" height="728" srcset="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=1024%2C728&amp;ssl=1 1024w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=300%2C213&amp;ssl=1 300w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?resize=768%2C546&amp;ssl=1 768w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/vscode.png?w=2000 2000w" sizes="(max-width: 1000px) 100vw, 1000px" data-recalc-dims="1" /></noscript>Just in case you haven&#8217;t been around the Chrome Unboxed site lately or Chromebook news in general, let me catch you up to speed on what could be one of the biggest developments ever to come to the Chrome OS ecosystem.<span id="more-5070"></span></p>
<p class="adHolder"><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p>
<h4>Containers</h4>
<p>We&#8217;re not talking about Tupperware® here. No, this is something exponentially more exciting and useful and you don&#8217;t have to worry about keeping track of the lids.</p>
<p>The containers we speak of are the type that run a specific instance of an application and rely mostly on the hardware of the machine or server they are running on with little to no dependency on a parent operating system.</p>
<p>This makes mass deployment of a particular app not only possible but efficient. The application can call on whatever amount of system resources it requires and do its thing without any other calls from OSes. Everything the app requires (outside of the hardware component) is packaged in a nice, clean &#8220;container.&#8221;</p>
<p>This is not to be confused with a &#8220;virtual machine&#8221; which, in essence, creates a virtual operating system and all of the things that come with it. If you&#8217;d like to learn more about virtual machines or even give on a try, check out <a href="http://fxo.co/5NtQ" target="_blank" rel="noopener">VMWare</a>.</p>
<p>The coolest part is that these two services can actually play together and that&#8217;s exactly what we&#8217;re seeing unfold in some upcoming features coming to Chrome OS.</p>
<p class="adHolder"><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p>
<p>The average user has been using a container on Chrome OS for some time now and may be completely unaware. Android apps on a Chromebook run in their very own containers. ARC (Android Runtime for Chrome) isolates Android apps inside Linux containers to sandbox them and maintain the integrity of the Chrome operating system.</p>
<h4>What&#8217;s Next?</h4>
<p>The next evolution of containers in Chrome OS has been the works for some time and we have had our suspicions about what Google is up to as far back as <a href="http://chromeunboxed.com/news/containers-and-chromebooks-the-future-of-chrome-os/" target="_blank" rel="noopener">October of last year</a>.</p>
<p>While the applications could be limitless, it&#8217;s more likely that the use of containers on Chrome OS will be targeting developers specifically in the coming months. Project &#8220;Crostini&#8221; has fleshed out as the branded name of the container platform that will deliver this functionality to Chromebooks and up until now, we&#8217;ve only seen <a href="http://chromeunboxed.com/news/chromebook-linux-terminal-crostini-first-look" target="_blank" rel="noopener">traces of Crostini inside of Chrome OS</a>.</p>
<p>For now, the UI side of Crostini still lays dormant awaiting the Chromium developers to flip the switch that will enable this new feature. However, thanks to some tinkerers who are way more knowledgeable than me, we have our first look at an actual application running inside of a container on Chrome OS using Crostini.</p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">VS Code running &#8220;natively&#8221; on my pixelbook thanks to crostini. Can&#8217;t wait for this to land properly! Looks like 2018 might be the year of Linux on the desktop for me. <a href="https://t.co/oGasHwcxj9">pic.twitter.com/oGasHwcxj9</a></p>
<p>— Lincoln Stoll (@lstoll) <a href="https://twitter.com/lstoll/status/975553814857158656?ref_src=twsrc%5Etfw">March 19, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><br />
Salesforce engineer Lincoln Stoll (@<a href="https://twitter.com/lstoll" target="_blank" rel="noopener">lstoll</a>) has spent some time getting the Crostini project working on his Pixelbook and has successfully spun up Visual Studio Code inside the container.</p>
<p>For developers, Crostini coming to the mainstream channels of Chrome OS could be a game changer as it could allow for the use of all the familiar tools they&#8217;re accustomed to all housed in the lightweight operating system that is Chrome OS. Google&#8217;s Pixelbook could, for all intents and purposes, become a standalone developer machine without all the &#8220;hackiness&#8221; that came with previous methods like Crouton.</p>
<p>Lincoln has gone so far as to lay out the method to this madness on his GitHub page, <a href="https://github.com/lstoll/cros-crostini" target="_blank" rel="noopener">here</a>. Be forewarned, this takes a decent level of expertise and I don&#8217;t recommend trying it unless you know what you&#8217;re doing and understand the risk to your device.</p>
<p>That being said, after receiving the tip about Stoll&#8217;s work, I spoke with my friend and colleague Dennis Lockhart who has also been experimenting with Crostini. He too has successfully launched applications using this method including running Ubuntu 14.04 and a nginx webserver all via a container on his Pixelbook.<br />
<div id="attachment_5072" style="max-width: 1003px" class="wp-caption aligncenter"><img data-attachment-id="5072" data-permalink="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/2018-03-24/" data-orig-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=993%2C580&amp;ssl=1" data-orig-size="993,580" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2018-03-24" data-image-description data-medium-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=300%2C175&amp;ssl=1" data-large-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=993%2C580&amp;ssl=1" src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" alt width="993" height="580" class="size-full wp-image-5072" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=993%2C580" data-lazy-srcset="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?w=993&amp;ssl=1 993w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=300%2C175&amp;ssl=1 300w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=768%2C449&amp;ssl=1 768w" data-lazy-sizes="(max-width: 993px) 100vw, 993px"><noscript><img data-attachment-id="5072" data-permalink="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine/2018-03-24/" data-orig-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=993%2C580&amp;ssl=1" data-orig-size="993,580" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2018-03-24" data-image-description="" data-medium-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=300%2C175&amp;ssl=1" data-large-file="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?fit=993%2C580&amp;ssl=1" src="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=993%2C580" alt="" width="993" height="580" class="size-full wp-image-5072" srcset="https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?w=993&amp;ssl=1 993w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=300%2C175&amp;ssl=1 300w, https://i1.wp.com/chromeunboxed.com/wp-content/uploads/2018/03/2018-03-24.png?resize=768%2C449&amp;ssl=1 768w" sizes="(max-width: 993px) 100vw, 993px" data-recalc-dims="1" /></noscript><p class="wp-caption-text">Image credit: Dennis Lockhart</p></div><br />
This is all really, really exciting stuff but for many, we&#8217;ve crossed over into some majorly nerdy stuff and I get that but trust me, the implications are HUGE! What will be more exhilarating is when the UI side of Crostini comes to full completion and all of this can be implemented via simple settings inside of Chrome OS.</p>
<h4>So, when?</h4>
<p>Well, from all the signs we&#8217;ve seen, Crostini is only working on version 66 and above of Chrome OS. Chrome OS 65 just rolled out and it brought with it greater than the average number of feature updates but version 66 will be coming around the first two weeks of May which just happens to coincide with a little developer event that&#8217;s taking place on the West coast.</p>
<p><a href="https://shareasale.com/r.cfm?b=1141247&amp;u=1722962&amp;m=41388&amp;urllink=&amp;afftrack=" target="_blank" rel="noopener"><img class="aligncenter" src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" border="0" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/static.shareasale.com/image/41388/PremiumWordPressHosting300x250.png"><noscript><img class="aligncenter" src="https://i1.wp.com/static.shareasale.com/image/41388/PremiumWordPressHosting300x250.png" border="0" data-recalc-dims="1" /></noscript></a><br />
<strong>That&#8217;s right, Google I/O.</strong></p>
<p>Google&#8217;s annual developer event that just happens to have a <a href="http://chromeunboxed.com/news/google-io-2018-schedule-chromebooks/" target="_blank" rel="noopener">session dedicated to Chromebooks</a> this year. While the new container features may not be ready for primetime by then, I would be shocked if we didn&#8217;t hear some mention of this new evolution of Chrome OS.</p>
<p>We&#8217;ll be tuning in for I/O and as usual, will have the feed posted here for you to watch along with us. Stay tuned for updates and join in the conversation below.</p>
<p>A very special thanks to Gavin Fernandes for emailing us this tip.</p>
<p><a class="BuyButton" href="https://www.amazon.com/gp/search/ref=as_li_qf_sp_sr_il_tl?ie=UTF8&amp;tag=chrome09d-20&amp;keywords=chromebooks&amp;index=aps&amp;camp=1789&amp;creative=9325&amp;linkCode=xm2&amp;linkId=022f1665307cb5ed559eaf057a69d66c" target="_blank" rel="nofollow noopener">Shop Chromebooks On Amazon</a></p>
<p><b>Source:</b> <a href="https://www.reddit.com/r/PixelBook/comments/85u5ll/working_vscode_on_pixelbook_via_debian_container/" target="_blank" rel="noopener">Reddit</a> via Gavin Fernandes</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share With Your People:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-5070" class="share-twitter sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-5070" class="share-facebook sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-5070" class="share-google-plus-1 sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div></div></div><!-- .entry-wrap --><footer class="entry-footer">	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links">
							<div class="nav-previous">
					<span class="nav-label">Previous Post</span>
					<a href="https://chromeunboxed.com/deal-alert-save-125-on-the-64gb-samsung-chromebook-pro/" rel="prev">Deal Alert: Save $125 On The 64GB Samsung Chromebook Pro</a>				</div>
					</div><!-- .nav-links -->
	</nav><!-- .navigation -->
</article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/lazy-images/images/1x1.trans.gif" class="avatar avatar-70 photo" height="70" width="70" data-lazy-src="https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=70&#038;d=mm&#038;r=g" data-lazy-srcset="https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=140&#038;d=mm&#038;r=g 2x"><noscript><img alt='' src='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></noscript><h4 class="author-box-title">About <span itemprop="name">Gabriel Brangers</span></h4><div class="author-box-content" itemprop="description"><p>Lover of all things coffee. Foodie for life. Passionate drummer, hobby guitar player, Web designer and proud Army Veteran. I have come to drink coffee and tell the world of all things Chrome. "Whatever you do, Carpe the heck out of that Diem" - Roman poet, Horace. Slightly paraphrased.</p>
</div></section>
<div id="disqus_thread"></div>
</main></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area">		<section id="recent-posts-7" class="widget widget_recent_entries"><div class="widget-wrap">		<h3 class="widgettitle widget-title">Recent Posts</h3>
		<ul>
											<li>
					<a href="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine">Visual Studio Code Spotted Running On Pixelbook Via Crostini Container</a>
									</li>
											<li>
					<a href="https://chromeunboxed.com/deal-alert-save-125-on-the-64gb-samsung-chromebook-pro/">Deal Alert: Save $125 On The 64GB Samsung Chromebook Pro</a>
									</li>
											<li>
					<a href="https://chromeunboxed.com/google-home-max-2-months-later/">Google Home Max: 2 Months Later</a>
									</li>
					</ul>
		</div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="search-6" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://chromeunboxed.com/" role="search"><meta itemprop="target" content="https://chromeunboxed.com/?s={s}"/><label class="search-form-label screen-reader-text" for="searchform-5ab737da2497f4.94901668">Search &#x2026;</label><input itemprop="query-input" type="search" name="s" id="searchform-5ab737da2497f4.94901668" placeholder="Search &#x2026;" /><input type="submit" value="&#xf002;" /></form></div></section>
<section id="simple-social-icons-5" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-email"><a href="mailto:info@chromeunboxed.com" target="_blank"><svg role="img" class="social-email" aria-labelledby="social-email"><title id="social-email">Email</title><use xlink:href="https://chromeunboxed.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email"></use></svg></a></li><li class="ssi-facebook"><a href="https://www.facebook.com/Chromeunboxed/" target="_blank"><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="https://chromeunboxed.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/111582298606053825151" target="_blank"><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="https://chromeunboxed.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/chromeunboxed" target="_blank"><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="https://chromeunboxed.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li><li class="ssi-youtube"><a href="http://www.youtube.com/channel/UCkHgegL2XiXSlwY5zeCKKyg" target="_blank"><svg role="img" class="social-youtube" aria-labelledby="social-youtube"><title id="social-youtube">YouTube</title><use xlink:href="https://chromeunboxed.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-youtube"></use></svg></a></li></ul></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="blog_subscription-5" class="widget jetpack_subscription_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Get Email Updates</h3>

			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-5">
				<div id="subscribe-text"></div><p>Join 3,944 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-5">
							Your email goes here...						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-5" placeholder="Your email goes here..." />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://chromeunboxed.com/news/chrome-os-container-crostini-vscode-virtual-machine" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-5" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-5]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-5'),
					input = d.getElementById('subscribe-field-blog_subscription-5'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 · Chrome Unboxed · <a href="http://google.com">Chrome is a registered trademark of Google Inc.</a><br><em>We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.</em></p><meta name="fo-verify" content="16268c33-f3a9-42f5-b0c1-17df5c0a1edd">
</div></footer></div>	<script type='text/javascript'>
	/* <![CDATA[ */
	var js_i18n = {"next":"next","back":"Back"};
	/* ]]> */
	</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=47710dc7-7dd9-465b-ab10-9a3bd20dbcbf"></script>


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chromeunboxed.com\/news\/chrome-os-container-crostini-vscode-virtual-machine":5070};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/news/chrome-os-container-crostini-vscode-virtual-machine" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://chromeunboxed.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://chromeunboxed.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"chrome-unboxed"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"5070 http:\/\/chromeunboxed.com\/?p=5070","disqusShortname":"chrome-unboxed","disqusTitle":"Visual Studio Code Spotted Running On Pixelbook Via Crostini Container","disqusUrl":"https:\/\/chromeunboxed.com\/news\/chrome-os-container-crostini-vscode-virtual-machine","postId":"5070"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201812'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/milan-pro/js/navigation.js?ver=1.1.38'></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=5.9'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/chromeunboxed.com\/wp-admin\/admin-ajax.php","nonce":"fa90109d1d","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/chromeunboxed.com\/wp-login.php?redirect_to=https%3A%2F%2Fchromeunboxed.com%2Fnews%2Fchrome-os-container-crostini-vscode-virtual-machine","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201812.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'112270166',post:'5070',tz:'-4',srv:'chromeunboxed.com'} ]);
	_stq.push([ 'clickTrackerInit', '112270166', '5070' ]);
</script>
</body></html>
