<!DOCTYPE html>
<html lang="en-US" id="arve">
<head ><meta charset="UTF-8" />
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var p=[],e="/porpoiseant/army.gif";function i(e,t,i,d,o,_,n){if(__ez.dot.isDefined(e,e.getSlotElementId)){var r=parseInt(e.getTargeting("ap")[0]),a=function(e){var t=0;try{var i=e.getTargetingMap(),d=e.getSlotElementId();if(-1===d.indexOf("div-gpt-ad"))return t;if(void 0!==i)for(var o in i)if(-1!==o.indexOf("iid")&&void 0!==i[o][0]){t=i[o][0];break}}catch(e){}return t}(e),g=e.getSlotElementId(),s=parseInt(e.getTargeting("compid")[0]);__ez.dot.isDefined(a,g)&&__ez.dot.isValid(t)&&p.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:g,t_epoch:__ez.dot.getEpoch(0),revenue:i,est_revenue:d,ad_position:r,ad_size:"",bid_floor_filled:o,bid_floor_prev:_,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:s,data:__ez.dot.dataToStr(t)})}}function d(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(p)&&0<p.length&&((new Image).src=__ez.dot.getURL(e)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(p))),p=[])}return{Add:i,AddAndFire:function(e,t){i(e,t,0,0,0,0,0),d()},AddById:function(e,t){var i=e.split("/");if(__ez.dot.isDefined(e)&&3===i.length&&__ez.dot.isValid(t)){var d=i[0],o=i[2];p.push({type:"impression",impression_id:o,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t)})}},Fire:d}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script>

<meta name="description" content="While we were more than a tad disappointed that Google did not announce the Pixelbook 2 alongside the upcoming Pixel Slate tablet, there are no shortages of Chromebooks to choose from if you’re in the market for a premium, powerful device. Just two days after Dell released their new Inspiron 14 Chromebook via Best Buy stores, Lenovo has followed suit with their 15.6″ Kaby Lake-powered convertible." />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Lenovo&#8217;s Massive Chromebook C630 Now Available From Best Buy</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//code.ionicframework.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Feed" href="https://chromeunboxed.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Comments Feed" href="https://chromeunboxed.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Lenovo&#8217;s Massive Chromebook C630 Now Available From Best Buy Comments Feed" href="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available/feed/" />
<link rel="canonical" href="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/chromeunboxed.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='genesis-simple-share-plugin-css-css'  href='//chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css'  href='//chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='no-sidebar-pro-css'  href='https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/style.css?ver=1.0.56' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C600%2C700%7COswald%3A300%7CPlayfair+Display%3A400%2C400italic%2C700&#038;ver=1.0.56' type='text/css' media='all' />
<link rel='stylesheet' id='ionicons-css'  href='//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css?ver=1.0.56' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://chromeunboxed.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='//chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0'></script>
<script type='text/javascript' src='//chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/waypoints.min.js?ver=0.1.0'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.10.7'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/advanced-ads-pro/modules/click-fraud-protection/assets/js/cfp.min.js?ver=2.2.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=4.9.8'></script>
<script type='text/javascript'>
(adsbygoogle = window.adsbygoogle || []).push({google_ad_client: "ca-pub-3946689793100734", enable_page_level_ads: true, tag_partner: "genesis"});
</script>
<link rel='https://api.w.org/' href='https://chromeunboxed.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chromeunboxed.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fnews%2Flenovo-chromebook-c630-15-inch-available" />
<link rel="alternate" type="text/xml+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fnews%2Flenovo-chromebook-c630-15-inch-available&#038;format=xml" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script><style type='text/css'>img#wpstats{display:none}</style><meta name="google-site-verification" content="heKdKP4cn3F3o5Bpy6diX_5mqJ7DSwReinb7QNQ6AE8" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78354183-1', 'auto');
  ga('send', 'pageview');

</script><style type="text/css">.site-title a { background: url(https://chromeunboxed.com/wp-content/uploads/2018/08/cropped-newCUlogo.png) no-repeat !important; }</style>
<!-- AB7CD46E-101E-4A29-A3E6-33E72A51FB43 -->
<meta name="theme-color" content="#FFFFFF" />
<link rel="amphtml" href="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available/amp/"><link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-180x180.png" />
<meta name="msapplication-TileImage" content="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-270x270.png" />

<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-107988763-46";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-107988763-46']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'chromeunboxed.com']);
_gaq.push(['f._setDomainName', 'chromeunboxed.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','chromeunboxed.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 75190;
var ezdomain = 'chromeunboxed.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":75190,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"fce05619-2721-4be3-52c7-07c75888f776","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":262,"serverid":"52.205.95.77:23105","state":"VA","t_epoch":1540189295,"template_id":126,"time_on_site_visit":0,"url":"https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available","user_id":0,"word_count":627};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=177-5&v=8" async></script><script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_75190=" + new Date().getTime() + "|fce05619-2721-4be3-52c7-07c75888f776; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="post-template-default single single-post postid-6234 single-format-standard custom-header header-image header-full-width full-width-content" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://chromeunboxed.com/">Chrome Unboxed - The Latest Chrome OS News</a></p><p class="site-description" itemprop="description">A Space for All Things Chrome</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-primary-navigation-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3111"><a href="https://chromeunboxed.com/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-2877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2877"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-5765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5765"><a href="https://chromeunboxed.com/unboxing/" itemprop="url"><span itemprop="name">Unboxing</span></a></li>
<li id="menu-item-5764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5764"><a href="https://chromeunboxed.com/upcoming-devices/" itemprop="url"><span itemprop="name">Upcoming</span></a></li>
<li id="menu-item-2878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2878"><a href="https://chromeunboxed.com/tips-tricks/" itemprop="url"><span itemprop="name">Tips</span></a></li>
<li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2873"><a href="https://chromeunboxed.com/chromebooks/" itemprop="url"><span itemprop="name">Chromebooks</span></a></li>
<li id="menu-item-2874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2874"><a href="https://chromeunboxed.com/chromecast/" itemprop="url"><span itemprop="name">Chromecast</span></a></li>
<li id="menu-item-3092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3092"><a href="https://chromeunboxed.com/google-assistant/" itemprop="url"><span itemprop="name">Assistant</span></a></li>
<li id="menu-item-2881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2881"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-5766" class="keepForMobile menu-item menu-item-type-post_type menu-item-object-page menu-item-5766"><a href="https://chromeunboxed.com/search-chrome-unboxed/" itemprop="url"><span itemprop="name">SEARCH</span></a></li>
</ul></div></nav><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://chromeunboxed.com/" role="search"><meta itemprop="target" content="https://chromeunboxed.com/?s={s}"/><label class="search-form-label screen-reader-text" for="searchform-5bcd4fcb45e456.71492569">Search</label><input itemprop="query-input" type="search" name="s" id="searchform-5bcd4fcb45e456.71492569" placeholder="Search" /><input type="submit" value="Search" /></form></div></header><div class="site-inner"><div class="content-sidebar-wrap"><div class="chrom-home-feed-top innerAds" style="text-align: center; margin-top: 10px; margin-bottom: 30px; " id="chrom-580559307"><!-- Ezoic - New-CU-Top - top_of_page -->
<div id="ezoic-pub-ad-placeholder-123">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="5328481604"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</div>
<!-- End Ezoic - New-CU-Top - top_of_page --></div><main class="content" id="genesis-content"><article class="post-6234 post type-post status-publish format-standard has-post-thumbnail category-chromebooks category-convertible category-news entry" itemscope itemtype="https://schema.org/CreativeWork"><div class="featured-image"><img src="https://chromeunboxed.com/wp-content/uploads/2018/10/6295998cv15a.jpg" alt="Lenovo&#8217;s Massive Chromebook C630 Now Available From Best Buy" /></div><header class="entry-header"><h1 class="entry-title" itemprop="headline">Lenovo&#8217;s Massive Chromebook C630 Now Available From Best Buy</h1>
<img alt='' src='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-10-21T18:52:07+00:00">October 21, 2018</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://chromeunboxed.com/author/gabe/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gabriel Brangers</span></a></span> <span class="entry-comments-link"><a href="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available#respond"><span class="dsq-postid" data-dsqidentifier="6234 http://chromeunboxed.com/?p=6234">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-medium" id="share-before-6234"><div class="googlePlus" id="googleplus-before-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div>
			<script type="text/javascript">
				jQuery(document).ready(function($) {
					$('#googleplus-before-6234').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-6234').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-6234').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'chromeunboxed' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});

				});
		</script><p>While we were more than a tad disappointed that Google did not announce the Pixelbook 2 alongside the upcoming Pixel Slate tablet, there are no shortages of Chromebooks to choose from if you’re in the market for a premium, powerful device.</p>
<p>Just two days after <a href="http://chromeunboxed.com/news/dell-inspiron-chromebook-14-available-best-buy/" target="_blank" rel="noopener">Dell released their new Inspiron 14 Chromebook</a> via Best Buy stores, Lenovo has followed suit with their 15.6″ Kaby Lake-powered convertible.<span id="more-6234"></span></p>
<p>Ever-watchful Kevin Tofel of About Chromebooks came across the Best Buy listing which currently includes the Core i5, 8GB/128GB models with either an FHD, 1920×1080 display or the <a href="http://chromeunboxed.com/news/lenovo-releases-three-new-chromebooks-premium-kaby-lake-ifa" rel="noopener" target="_blank">highly-anticipated 4K panel</a>. Sadly, the UltraHD version is out of stock at the moment.</p><div class="chrom-content innerAds" style="text-align: center; margin-top: 10px; margin-bottom: 50px; " id="chrom-130219842"><!-- Ezoic - New-CU-Content-1 - mid_content -->
<div id="ezoic-pub-ad-placeholder-127">
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- In Content Ad --><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<!-- End Ezoic - New-CU-Content-1 - mid_content --></div>
<p>Apart from its massive size, one of the most interesting features of Lenovo’s C630 Chromebook is without a doubt the price. The FHD model comes in at a very conservative $699.</p>
<p>Now, I know what you’re thinking. Seven hundred dollars for a Chromebook? Yes, but you’ll be getting some serious horsepower under the hood. You might be quick to think this Chromebook will be in the same realm of performance as the Pixelbook seeing that it is a Core i5. I can attest, you’d be incorrect.</p>
<p>The 8th gen, Kaby Lake Core i5-8250U is in a whole different class than the mobile-focused processor in Google’s flagship. Granted, the Lenovo’s processor is fanned so that is something to consider before making your purchase.</p><div class="chrom-content-1 innerAds" style="text-align: center; margin-top: 10px; margin-bottom: 50px; " id="chrom-1938307383"><!-- Ezoic - New-CU-Content-2 - mid_content -->
<div id="ezoic-pub-ad-placeholder-126">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- In Content Ad --><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<!-- End Ezoic - New-CU-Content-2 - mid_content -->

</div>
<p>I have had the pleasure of working from the Acer Chromebook Spin 13 for the past week or so and while the fan does produce its fair share of noise, I don’t find it to be a nuisance and the performance boost over the 7th gen Core i5 Y-series chip is significant.</p>
<p>With that in mind, I don’t mean to say that the Lenovo outclasses the Pixelbook: simply that it will beat Google’s Chromebook in a head-to-head benchmark battle. And, it will do so all while costing you at least $200 less than the Pixelbook.</p>
<p>For me, a 15,6″ Chromebook doesn’t make a lot of sense and honestly, I’m not a fan of the convertible form-factor on a device this large. That’s just me. I know there are a lot of people who have been looking forward to getting their hands on this Chromebook, and now they can.</p>
<p>We’ll be getting our hands on this bad boy ASAP. If you’re still on the fence, you can look forward to a full review very soon. If you happen to have a Best Buy near you, it might be a good time to take a drive and see what’s new in the Chromebook section.</p>
<p><a href="http://fxo.co/6Hz2" rel="nofollow" target="_blank" class="BuyButton">Shop the Lenovo Chromebook C630 from Best Buy</a></p>
<p><b>Source:</b> <a href="https://www.aboutchromebooks.com/news/lenovo-yoga-chromebook-c630-price-availability-4k/" rel="noopener" target="_blank">About Chromebooks</a></p>
<div class="share-after share-filled share-medium" id="share-after-6234"><div class="googlePlus" id="googleplus-after-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-after-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-after-6234" data-url="https://chromeunboxed.com/news/lenovo-chromebook-c630-15-inch-available" data-urlalt="https://wp.me/p7B4B8-1Cy" data-text="Lenovo’s Massive Chromebook C630 Now Available From Best Buy" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div>
			<script type="text/javascript">
				jQuery(document).ready(function($) {
					$('#googleplus-after-6234').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-after-6234').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-after-6234').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'chromeunboxed' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});

				});
		</script><div id="jp-relatedposts" class="jp-relatedposts">
	
</div>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://chromeunboxed.com/chromebooks/" rel="category tag">Chromebooks</a>, <a href="https://chromeunboxed.com/convertible/" rel="category tag">Convertible</a>, <a href="https://chromeunboxed.com/news/" rel="category tag">News</a></span> </p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=160&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bba376b6ab079c361c6ddb56ce19459f?s=320&#038;d=mm&#038;r=g 2x' class='avatar avatar-160 photo' height='160' width='160' /><h4 class="author-box-title">About <span itemprop="name">Gabriel Brangers</span></h4><div class="author-box-content" itemprop="description"><p>Lover of all things coffee. Foodie for life. Passionate drummer, hobby guitar player, Web designer and proud Army Veteran. I have come to drink coffee and tell the world of all things Chrome. "Whatever you do, Carpe the heck out of that Diem" - Roman poet, Horace. Slightly paraphrased.</p>
</div></section>
<div id="disqus_thread"></div>
</main></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p class="socialLinks"><a href="https://twitter.com/chromeunboxed" target="_blank">TWITTER</a> | <a href="https://www.facebook.com/Chromeunboxed/" target="_blank">FACEBOOK</a> | <a href="https://instagram.com/chromeunboxed/" target="_blank">INSTAGRAM</a> | <a href="https://plus.google.com/111582298606053825151" target="_blank">GOOGLE+</a> | <a href="http://www.youtube.com/channel/UCkHgegL2XiXSlwY5zeCKKyg" target="_blank">YOUTUBE</a> | <a href="mailto:info@chromeunboxed.com" target="_blank">EMAIL</a></p>
<div class="divider"></div>
<p>Copyright &#x000A9;&nbsp;2018 · Chrome Unboxed · <a href="http://google.com">Chrome is a registered trademark of Google Inc.</a><br><em>We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.</em></p>
<p><a href="/newsletter-sign-up/" class="footerButton">GET EMAIL UPDATES</a></p>
<p><a class="footerButton" href="https://g.ezoic.net/privacy/chromeunboxed.com" target="_blank">Privacy Policy</a></p><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav-2" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-864"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287"><a href="https://chromeunboxed.com/editorial/" itemprop="url"><span itemprop="name">Editorial</span></a></li>
<li id="menu-item-285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-285"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
</ul></div></nav></div></footer></div><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"chrome-unboxed"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"6234 http:\/\/chromeunboxed.com\/?p=6234","disqusShortname":"chrome-unboxed","disqusTitle":"Lenovo\u2019s Massive Chromebook C630 Now Available From Best Buy","disqusUrl":"https:\/\/chromeunboxed.com\/news\/lenovo-chromebook-c630-15-inch-available","postId":"6234"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201843'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.5'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=2.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var NoSidebarL10n = {"mainMenu":"Menu","subMenu":"Menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/search-box.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/fadein.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201843.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.6.1',blog:'112270166',post:'6234',tz:'-4',srv:'chromeunboxed.com'} ]);
	_stq.push([ 'clickTrackerInit', '112270166', '6234' ]);
</script>
<!--Begin comScore Tag--><script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20015427"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el)})();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript><!--End comScore Tag-->
<!--Quantcast Tag--><script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt)})();_qevents.push({qacct:"p-31iz6hfFutd16",labels:"Domain.chromeunboxed_com,DomainId.75190"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.chromeunboxed_com,DomainId.75190"border="0"height="1"width="1"alt="Quantcast"/></div></noscript><!--End Quantcast tag-->
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '//chromeunboxed.com/detroitchicago/edmonton.webp?a=a&cb=5&shcb=31', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '//chromeunboxed.com/porpoiseant/jellyfish.webp?a=a&cb=5&shcb=31', false, [], true, false, false, false);
</script>
</body></html>
