<!DOCTYPE html>
<html lang="en-US" id="arve">
<head ><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>

<meta name="description" content="The Lenovo Flex 5 Chromebook has been around for a few weeks in the Core i3 variant, but now we&#039;re seeing the Celeron versions begin to surface at Best Buy." />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="TxKFgqoM9wSS_5tNVu2Tfyy2LhgsK5yFVEZXV80wICU" />
<link rel="amphtml" href="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/?amp" /><meta name="generator" content="AMP for WP 1.0.52"/><link rel='dns-prefetch' href='//code.ionicframework.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Feed" href="https://chromeunboxed.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Comments Feed" href="https://chromeunboxed.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; 2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy Comments Feed" href="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/feed/" />
<link rel="canonical" href="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/chromeunboxed.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="genesis-simple-share-plugin-css-css" href="https://cdn-0.chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/css/share.min.css?ver=0.1.0" type="text/css" media="all"/>
<link rel="stylesheet" id="genesis-simple-share-genericons-css-css" href="https://cdn-0.chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/css/genericons.min.css?ver=0.1.0" type="text/css" media="all"/>
<link rel="stylesheet" id="no-sidebar-pro-css" href="https://cdn-0.chromeunboxed.com/wp-content/themes/no-sidebar-pro/style.css?ver=1.0.141" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-block-library-css" href="https://cdn-0.chromeunboxed.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1" type="text/css" media="all"/>
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ionicons-css'  href='//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css?ver=1.0.141' type='text/css' media='all' />
<link rel="stylesheet" id="jetpack_css-css" href="https://cdn-0.chromeunboxed.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1" type="text/css" media="all"/>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/waypoints.min.js?ver=0.1.0"></script>
<!-- OG: 2.8.3 -->
<meta property="og:image" content="https://chromeunboxed.com/wp-content/uploads/2020/06/lenovoFlex5CeleronBestBuy.jpg" /><meta property="og:image:secure_url" content="https://chromeunboxed.com/wp-content/uploads/2020/06/lenovoFlex5CeleronBestBuy.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta property="og:image:alt" content="lenovoFlex5CeleronBestBuy" /><meta property="og:image:type" content="image/jpeg" /><meta property="og:description" content="As I&#039;m nearing the end of my review process with the Lenovo Flex 5 Chromebook, I honestly don&#039;t care if I spoil it just a little bit. As I alluded to yesterday when I declared this Chromebook a disruption to the Chromebook status quo, the Flex 5 is quite excellent at many things and I..." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="Chrome Unboxed - The Latest Chrome OS News" /><meta property="og:title" content="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" /><meta property="og:url" content="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" /><meta property="og:updated_time" content="2020-06-04T10:05:12-04:00" /><meta property="article:published_time" content="2020-06-04T10:05:09-04:00" /><meta property="article:modified_time" content="2020-06-04T10:05:12-04:00" /><meta property="article:author" content="https://chromeunboxed.com/author/robbypayne/" /><meta property="article:section" content="Chromebooks" /><meta property="article:section" content="News" /><meta property="article:section" content="Upcoming Devices" /><meta property="twitter:partner" content="ogwp" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:title" content="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" /><meta property="twitter:description" content="As I&#039;m nearing the end of my review process with the Lenovo Flex 5 Chromebook, I honestly don&#039;t care if I spoil it just a little bit. As I alluded to yesterday when I declared this Chromebook a disruption to the Chromebook status quo, the Flex 5 is quite excellent at many things and I..." /><meta property="twitter:url" content="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" /><meta property="twitter:image" content="https://chromeunboxed.com/wp-content/uploads/2020/06/lenovoFlex5CeleronBestBuy.jpg" /><meta property="profile:first_name" content="Robby" /><meta property="profile:last_name" content="Payne" /><meta property="profile:username" content="Robby Payne" /><!-- /OG -->
<link rel='https://api.w.org/' href='https://chromeunboxed.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chromeunboxed.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Flenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Flenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style><meta name="google-site-verification" content="heKdKP4cn3F3o5Bpy6diX_5mqJ7DSwReinb7QNQ6AE8" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78354183-1', 'auto');
  ga('send', 'pageview');

</script>

<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#2b5797">
<meta name="theme-color" content="#ffffff">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-3946689793100734",
enable_page_level_ads: true,
tag_partner: "genesis"
});
</script>


<meta name='ir-site-verification-token' value='2056768303' /><style type="text/css">.site-title a { background: url(https://cdn-0.chromeunboxed.com/wp-content/uploads/2019/01/cropped-newCUlogo-2.png) no-repeat !important; }</style>
<!-- AB7CD46E-101E-4A29-A3E6-33E72A51FB43 -->
<meta name="theme-color" content="#FFFFFF" />
<link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://chromeunboxed.com/wp-content/uploads/2017/06/cropped-cuSiteIcon-1-270x270.png" />

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-107988763-46";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-107988763-46']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'chromeunboxed.com']);
_gaq.push(['f._setDomainName', 'chromeunboxed.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod22',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','chromeunboxed.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 75190;
var ezdomain = 'chromeunboxed.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":75190,"domain_test_group":20200406,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"0ca508db-2d6a-4464-4619-36b54674ce4c","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":419,"serverid":"3.235.252.121:13255","state":"VA","t_epoch":1591284858,"template_id":126,"time_on_site_visit":0,"url":"https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/","user_id":0,"word_count":985,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-5&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_75190=" + new Date().getTime() + "|0ca508db-2d6a-4464-4619-36b54674ce4c|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="post-template-default single single-post postid-18679 single-format-standard custom-header header-image header-full-width full-width-content genesis-breadcrumbs-visible" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li></ul><div class="topSpace">

<!-- <a href="https://chromeunboxed.com/chrome-unboxed-100000-youtube-subscriber-giveaway-pixel-chromebook-flip-c434/" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/02/onTheRun100KHeader2.jpg" class="desktopHeader"></a>

<a href="https://chromeunboxed.com/chrome-unboxed-100000-youtube-subscriber-giveaway-pixel-chromebook-flip-c434/" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/02/onTheRun100KHeaderMobile.jpg" class="mobileHeader"></a>

<a href="https://fave.co/2QQx9iN" target="_blank"><img src="https://chromeunboxed.com/wp-content/uploads/2020/03/BHphotoBannerHeaderFinal.jpg" class="desktopHeader"></a>

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120"><img src="https://chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020mobileFull70off-3.jpg" class="mobileHeader"></a>

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120"><img src="https://chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020mobileFull70off-3.jpg" class="mobileHeader"></a>

-->

<a href="https://go.nordvpn.net/aff_c?offer_id=15&aff_id=19181&url_id=12&source=Website-0120" target="_blank"><img src="https://cdn-0.chromeunboxed.com/wp-content/uploads/2020/01/nordVPNbannerJan2020Full70off-3.jpg" class="desktopHeader"></a>

</div><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://chromeunboxed.com/">Chrome Unboxed - The Latest Chrome OS News</a></p><p class="site-description" itemprop="description">A Space for All Things Chrome, Google, and More!</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-primary-navigation-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3111"><a href="https://chromeunboxed.com/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-2877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2877"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-5765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5765"><a href="https://chromeunboxed.com/unboxing/" itemprop="url"><span itemprop="name">Unboxing</span></a></li>
<li id="menu-item-8136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8136"><a href="https://chromeunboxed.com/deals/" itemprop="url"><span itemprop="name">Deals</span></a></li>
<li id="menu-item-5764" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5764"><a href="https://chromeunboxed.com/upcoming-devices/" itemprop="url"><span itemprop="name">Upcoming</span></a></li>
<li id="menu-item-2878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2878"><a href="https://chromeunboxed.com/tips-tricks/" itemprop="url"><span itemprop="name">Tips</span></a></li>
<li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2873"><a href="https://chromeunboxed.com/chromebooks/" itemprop="url"><span itemprop="name">Chromebooks</span></a></li>
<li id="menu-item-3092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3092"><a href="https://chromeunboxed.com/google-assistant/" itemprop="url"><span itemprop="name">Assistant</span></a></li>
<li id="menu-item-8361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8361"><a href="https://chromeunboxed.com/podcast/" itemprop="url"><span itemprop="name">Podcast</span></a></li>
<li id="menu-item-2881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2881"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-5766" class="keepForMobile menu-item menu-item-type-post_type menu-item-object-page menu-item-5766"><a href="https://chromeunboxed.com/search-chrome-unboxed/" itemprop="url"><span itemprop="name">SEARCH</span></a></li>
</ul></div></nav><form class="search-form" method="get" action="https://chromeunboxed.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://chromeunboxed.com/?s={s}" itemprop="target"></form></div></header><div class="site-inner"><div class="content-sidebar-wrap"><!-- Ezoic - New-CU-Top - top_of_page -->
<div id="ezoic-pub-ad-placeholder-123">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="5328481604"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
	</div>
<!-- End Ezoic - New-CU-Top - top_of_page --><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://chromeunboxed.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://chromeunboxed.com/chromebooks/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Chromebooks</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> 2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy</div><article class="post-18679 post type-post status-publish format-standard has-post-thumbnail category-chromebooks category-news category-upcoming-devices entry" itemscope itemtype="https://schema.org/CreativeWork"><div class="featured-image"><img src="https://cdn-0.chromeunboxed.com/wp-content/uploads/2020/06/lenovoFlex5CeleronBestBuy.jpg" alt="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy"/></div><header class="entry-header"><h1 class="entry-title" itemprop="headline">2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy</h1>
<img alt='' src='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-06-04T10:05:09-04:00">June 4, 2020</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://chromeunboxed.com/author/robbypayne/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Robby Payne</span></a></span> <span class="entry-comments-link"><a href="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/#respond"><span class="dsq-postid" data-dsqidentifier="18679 https://chromeunboxed.com/?p=18679">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-medium" id="share-before-18679"><div class="googlePlus" id="googleplus-before-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-before-18679').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-18679').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-18679').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'chromeunboxed' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});

				});
		</script>
<p>As I&#8217;m nearing the end of my review process with the Lenovo Flex 5 Chromebook, <strong>I honestly don&#8217;t care if I spoil it just a little bit.</strong>  As I alluded to yesterday when <a href="https://chromeunboxed.com/lenovo-flex-5-duet-chromebook-affordable-quality-disruption/" target="_blank" rel="noopener">I declared this Chromebook a disruption to the Chromebook status quo, </a>the Flex 5 is quite excellent at many things and I think as availability expands and more versions hit the market, we are going to see better Chromebooks coming down in price and lower-priced Chromebooks getting better in quality.  I&#8217;ll hold the rest of my thoughts for the full review coming soon, but today it seems that the broader offerings of the Lenovo Flex 5 Chromebook may be just around the corner.</p><div class='code-block code-block-1' style='margin: 0px auto 20px; text-align: center; display: block; clear: both;'>
<div id="ezoic-pub-ad-placeholder-127">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="5328481604"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>




<p><strong>Two new listings for the Celeron versions of the Flex 5 have shown up on the Best Buy website with the prices adjusted accordingly.</strong>  The most entry-level option is the <a href="https://fave.co/2AyzdH3" target="_blank" rel="noopener">Flex 5 with a Celeron 5205U, 4GB of RAM and 32GB of eMMC storage for $359.</a>  The other model <a href="https://fave.co/3dzW2bX" target="_blank" rel="noopener">keeps things the same and bumps up the internal storage to 64GB and the price to $379.</a>  Of course, the Core i3 model with 4GB of RAM and 64GB of storage that we&#8217;re testing comes in at $409.  At the moment, <a href="https://chromeunboxed.com/lenovo-flex-5-chromebook-core-i5-8gb-ram-128gb-nvme-coming-soon/" target="_blank" rel="noopener">we know a Core i5 version exists with 8GB of RAM and 128GB of internal NVMe storage,</a> but we&#8217;ve not seen it actually up for sale just yet.  And, technically, these Celeron versions aren&#8217;t up for sale just yet either as both show up on the Best Buy website as &#8216;sold out.&#8217;</p>



<p>From what we can tell, the only downgrade in the Celeron versions (apart from the processor) is the loss of keyboard backlighting.  Users who choose these models will still get the same build, great keyboard, mylar trackpad, 300 nit IPS screen, upward-firing speakers, Bluetooth 5 and WiFi 6 inside.  It&#8217;s a stellar package for under $400 to be sure, but just as I submitted yesterday that the $409 Core i3-powered Flex 5 would disrupt the Chrome OS world, <strong>I think Lenovo may have gone and disrupted itself in the process.</strong></p><div class='code-block code-block-2' style='margin: 0px auto 20px; text-align: center; display: block; clear: both;'>
<div id="ezoic-pub-ad-placeholder-126">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="5328481604"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>




<p>With the pricing so low on this well-rounded Chromebook, it becomes an odd choice for many to save very little money to make some rather large compromises.  First up, I wouldn&#8217;t tell anyone to buy a Chromebook with only 32GB of storage these days.  Sure, there are insane deals here and there and when you can get a Chromebook for less than $200, 32GB of storage is fine.  But when you aren&#8217;t chasing a crazy deal, there&#8217;s almost no reason to skip the upgraded storage. <strong> In the case of these new Flex 5 listings, we&#8217;re only talking $20 to double that storage, so I&#8217;d firmly recommend going that route.</strong></p>



<p>That being said, now we&#8217;re talking $379 for a device that will be slower and less-equipped than the version that only costs $30 more.  Upgrading to the Core i3 is a big step up in performance and having a backlit keyboard comes in more handy than you may realize.  Even comparing the cheapest model to the Core i3 version, you&#8217;re only saving $50.  Over the course of the 8 years you may own this Chromebook, <strong>you&#8217;ll wish many times over that you just found that extra $50 at the time of purchase.  Trust me.</strong></p>



<p>We usually see upgrades in storage and processors tip the scales at $100+, so the decision to accept trade-offs in those scenarios makes more sense.  With only $50 of separation, however, I think most users should just go and buy the $409 version over at Amazon or wherever it ends up becoming available in the future.  The price gap is too low and the performance gap too high not to recommend that you hold off on a few coffees and dinners at your favorite restaurant in order to <strong>scrape up the extra $50 to get the machine I think you&#8217;ll be far happier with over time.</strong>  </p><div class='code-block code-block-3' style='margin: 0px auto 20px; text-align: center; display: block; clear: both;'>
<div id="ezoic-pub-ad-placeholder-606">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- In Content Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3946689793100734"
     data-ad-slot="5328481604"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>




<p><strong>Again, I come back to disruption. </strong> This is what Lenovo has created for others and, as it turns out, for itself.  I&#8217;d be surprised if these Celeron models don&#8217;t dip in price almost immediately upon their full availability.  If the entry-level version could be had for less than $300, I suppose we&#8217;d be in for a much different conversation.  As it stands these days, however, MSRP is where things tend to stay, so we can only guess at when we&#8217;ll start seeing big discounts again.  <strong>While we&#8217;re in this reality, then, I&#8217;d highly recommend giving the Core i3 Flex 5 a very hard look.</strong></p>



<p><a href="https://chrmshop.com/lenovo-chromebook-flex-5/" target="_blank" class="BuyButton" rel="noopener">Shop the Lenovo Flex 5 Chromebook at Chrome Shop</a></p>



<div class="newsletterSignupBlock">
	Get Alerted About New Posts On <br class="forMobileOnly"><span class="highlighter">Your Schedule</span><br>
	<a class="BuyButton" href="https://chromeunboxed.com/newsletter-sign-up/" target="_blank" rel="noopener">Sign Up For The Official Chrome Unboxed Newsletter</a>
</div>
<div class="share-after share-filled share-medium" id="share-after-18679"><div class="googlePlus" id="googleplus-after-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-after-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-after-18679" data-url="https://chromeunboxed.com/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3/" data-urlalt="https://chromeunboxed.com/?p=18679" data-text="2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-after-18679').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-after-18679').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-after-18679').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'chromeunboxed' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});

				});
		</script><!-- AI CONTENT END 1 -->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://chromeunboxed.com/chromebooks/" rel="category tag">Chromebooks</a>, <a href="https://chromeunboxed.com/news/" rel="category tag">News</a>, <a href="https://chromeunboxed.com/upcoming-devices/" rel="category tag">Upcoming Devices</a></span> </p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=160&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=320&#038;d=mm&#038;r=g 2x' class='avatar avatar-160 photo' height='160' width='160' /><h4 class="author-box-title">About <span itemprop="name">Robby Payne</span></h4><div class="author-box-content" itemprop="description"><p>Tech junkie.  Musician.  Web Developer.  Coffee Snob.  Huge fan of the Google things.  Founded Chrome Unboxed because so many of my passions collide in this space.  I like that.  I want to share that.  I hope you enjoy it too.</p>
</div></section>
<div id="disqus_thread"></div>
</main></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p class="socialLinks"><a href="https://twitter.com/chromeunboxed" target="_blank">TWITTER</a> | <a href="https://www.facebook.com/Chromeunboxed/" target="_blank">FACEBOOK</a> | <a href="https://instagram.com/chromeunboxed/" target="_blank">INSTAGRAM</a> | <a href="https://mewe.com/page/5c6478173aebe52b522eccea" target="_blank">MEWE</a> | <a href="http://www.youtube.com/channel/UCkHgegL2XiXSlwY5zeCKKyg" target="_blank">YOUTUBE</a> | <a href="mailto:info@chromeunboxed.com" target="_blank">EMAIL</a></p>
<div class="divider"></div>
<p>Copyright &#x000A9;&nbsp;2020 · Chrome Unboxed · <a href="http://google.com">Chrome is a registered trademark of Google Inc.</a><br><em>We are participants in various affiliate advertising programs designed to provide a means for us to earn fees by linking to affiliated sites.</em></p>
<p><a href="/newsletter-sign-up/" class="footerButton">GET EMAIL UPDATES</a></p>
<p><a class="footerButton" href="https://g.ezoic.net/privacy/chromeunboxed.com" target="_blank">Privacy Policy</a></p><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav-2" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-864"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287"><a href="https://chromeunboxed.com/editorial/" itemprop="url"><span itemprop="name">Editorial</span></a></li>
<li id="menu-item-285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-285"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
</ul></div></nav></div></footer></div><script type="text/javascript" src="https://s.skimresources.com/js/128737X1590626.skimlinks.js"></script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"chrome-unboxed"};
/* ]]> */
</script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"18679 https:\/\/chromeunboxed.com\/?p=18679","disqusShortname":"chrome-unboxed","disqusTitle":"2 new listings for the Lenovo Flex 5 Chromebook appear at Best Buy","disqusUrl":"https:\/\/chromeunboxed.com\/lenovo-flex-5-chromebook-celeron-models-best-buy-disruption-core-i3\/","postId":"18679"};
/* ]]> */
</script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-includes/js/comment-reply.min.js?ver=5.4.1"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.2"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.2"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var NoSidebarL10n = {"mainMenu":"Menu","subMenu":"Menu"};
/* ]]> */
</script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/responsive-menu.js?ver=1.0.0"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-content/themes/no-sidebar-pro/js/search-box.js?ver=1.0.0"></script>
<script type="text/javascript" src="https://cdn-0.chromeunboxed.com/wp-includes/js/wp-embed.min.js?ver=5.4.1"></script>
<script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'112270166',post:'18679',tz:'-4',srv:'chromeunboxed.com'} ]);
	_stq.push([ 'clickTrackerInit', '112270166', '18679' ]);
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=5&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=5&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="chromeunboxed_com",_audins_did=75190;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-5");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.chromeunboxed_com,DomainId.75190" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>
