<!DOCTYPE html>
<html lang="en-US" id="arve">
<head ><meta charset="UTF-8"/>
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var z=[],i="/porpoiseant/army.gif";function t(e,i,t,d,_,o,n){if(__ez.dot.isDefined(e,e.getSlotElementId)){var a=parseInt(e.getTargeting("ap")[0]),r=function(e){var i=0;try{var t=e.getTargetingMap(),d=e.getSlotElementId();if(-1===d.indexOf("div-gpt-ad"))return i;if(void 0!==t)for(var _ in t)if(-1!==_.indexOf("iid")&&void 0!==t[_][0]){i=t[_][0];break}}catch(e){}return i}(e),s=e.getSlotElementId(),p=parseInt(e.getTargeting("compid")[0]),g=0,v=0;if("object"==typeof _ezim_d){var m=e.getAdUnitPath().split("/").pop();void 0!==_ezim_d[m]&&(void 0!==_ezim_d[m].creative_id&&(v=_ezim_d[m].creative_id),void 0!==_ezim_d[m].line_item_id&&(g=_ezim_d[m].line_item_id))}__ez.dot.isDefined(r,s)&&__ez.dot.isValid(i)&&z.push({type:"impression",impression_id:r,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:d,ad_position:a,ad_size:"",bid_floor_filled:_,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:g,creative_id:v,data:__ez.dot.dataToStr(i)})}}function d(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(z)&&0<z.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(z));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}z=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),d()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var d=t[0],_=t[2];z.push({type:"impression",impression_id:_,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:d}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script>

<meta name="description" content="Chrome, as a platform, is constantly evolving. We&#039;re seeing a new feature coming in Chrome OS 76 that pushes the limits of what we expect from the not-so-humble browser."/>
<meta name="robots" content="noodp,noydir"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
<title>Pull Text Right From Photos With Crazy New Feature Coming To Chrome</title>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com'/>
<link rel='dns-prefetch' href='//code.ionicframework.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Feed" href="https://chromeunboxed.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Comments Feed" href="https://chromeunboxed.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Chrome Unboxed - The Latest Chrome OS News &raquo; Pull Text Right From Photos With Crazy New Feature Coming To Chrome Comments Feed" href="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/feed/"/>
<link rel="canonical" href="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/"/>
<script data-wpfc-render="false">advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script><style>img.wp-smiley,
img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important;}</style>
<link rel="stylesheet" type="text/css" href="//chromeunboxed.com/wp-content/cache/wpfc-minified/2nibnem0/6it5y.css" media="all"/>
<link rel='stylesheet' id='ionicons-css' href='//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css?ver=1.0.64' type='text/css' media='all'/>
<link rel="stylesheet" type="text/css" href="//chromeunboxed.com/wp-content/cache/wpfc-minified/6zamxrpi/6it5h.css" media="all"/>
<script type='text/javascript' async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=2.10.1'></script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client: "ca-pub-3946689793100734", enable_page_level_ads: true, tag_partner: "genesis"});</script>
<link rel='https://api.w.org/' href='https://chromeunboxed.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chromeunboxed.com/xmlrpc.php?rsd"/>
<link rel="alternate" type="application/json+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fchrome-76-text-from-photos-android-windows%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://chromeunboxed.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchromeunboxed.com%2Fchrome-76-text-from-photos-android-windows%2F&#038;format=xml"/>
<style>img#wpstats{display:none}</style><link rel="icon" href="https://chromeunboxed.com/wp-content/themes/no-sidebar-pro/images/favicon.ico"/>
<meta name="google-site-verification" content="heKdKP4cn3F3o5Bpy6diX_5mqJ7DSwReinb7QNQ6AE8"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-78354183-1', 'auto'); ga('send', 'pageview');</script>
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#2b5797">
<meta name="theme-color" content="#ffffff"><style>.site-title a{background:url(https://chromeunboxed.com/wp-content/uploads/2018/08/cropped-newCUlogo.png) no-repeat !important;}</style>
<meta name="theme-color" content="#FFFFFF"/>
<script data-wpfc-render="false">var Wpfcll={s:[],osl:0,i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.osl=Wpfcll.s.length;Wpfcll.ss();if(Wpfcll.s.length > Wpfcll.osl){Wpfcll.ls(false);}},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;if(typeof p.getBoundingClientRect=="undefined"){var pr=false;}else{var pr=p.getBoundingClientRect();}if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;if(typeof p.getBoundingClientRect=="undefined"){pr=false;}else{pr=p.getBoundingClientRect();}}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(s.c(e,pageload)){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){if(typeof window.jQuery !="undefined"){if(jQuery.fn.fitVids){jQuery(e).parent().fitVids({customSelector:"iframe[src]"});}}var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>

<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-107988763-46";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-107988763-46']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'chromeunboxed.com']);
_gaq.push(['f._setDomainName', 'chromeunboxed.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod36-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','chromeunboxed.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 75190;
var ezdomain = 'chromeunboxed.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":75190,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"9717b560-981a-4770-59d7-ba2d5190304a","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":6,"serverid":"3.216.78.247:12934","state":"VA","t_epoch":1558392412,"template_id":126,"time_on_site_visit":0,"url":"https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/","user_id":0,"word_count":629,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=184-5&v=8" async></script>
<script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_75190=" + new Date().getTime() + "|9717b560-981a-4770-59d7-ba2d5190304a; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="post-template-default single single-post postid-8733 single-format-standard custom-header header-image header-full-width full-width-content" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://chromeunboxed.com/">Chrome Unboxed - The Latest Chrome OS News</a></p><p class="site-description" itemprop="description">A Space for All Things Chrome, Google, and More!</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-primary-navigation-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3111"><a href="https://chromeunboxed.com/news/" itemprop="url"><span itemprop="name">News</span></a></li> <li id="menu-item-2877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2877"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li> <li id="menu-item-5765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5765"><a href="https://chromeunboxed.com/unboxing/" itemprop="url"><span itemprop="name">Unboxing</span></a></li> <li id="menu-item-8136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8136"><a href="https://chromeunboxed.com/deals/" itemprop="url"><span itemprop="name">Deals</span></a></li> <li id="menu-item-5764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5764"><a href="https://chromeunboxed.com/upcoming-devices/" itemprop="url"><span itemprop="name">Upcoming</span></a></li> <li id="menu-item-2878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2878"><a href="https://chromeunboxed.com/tips-tricks/" itemprop="url"><span itemprop="name">Tips</span></a></li> <li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2873"><a href="https://chromeunboxed.com/chromebooks/" itemprop="url"><span itemprop="name">Chromebooks</span></a></li> <li id="menu-item-3092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3092"><a href="https://chromeunboxed.com/google-assistant/" itemprop="url"><span itemprop="name">Assistant</span></a></li> <li id="menu-item-8361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8361"><a href="https://chromeunboxed.com/podcast/" itemprop="url"><span itemprop="name">Podcast</span></a></li> <li id="menu-item-2881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2881"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li> <li id="menu-item-5766" class="keepForMobile menu-item menu-item-type-post_type menu-item-object-page menu-item-5766"><a href="https://chromeunboxed.com/search-chrome-unboxed/" itemprop="url"><span itemprop="name">SEARCH</span></a></li> </ul></div></nav><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://chromeunboxed.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-5ce32767c58572.32923754">Search</label><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-5ce32767c58572.32923754" placeholder="Search"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://chromeunboxed.com/?s={s}"></form></div></header><div class="site-inner"><div class="newSideAdLeft"></div><div class="newSideAdRight"></div><div class="content-sidebar-wrap"><div class="chrom-home-feed-top innerAds" style="text-align: center;" id="chrom-1998825050">
<div id="ezoic-pub-ad-placeholder-123">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-3946689793100734"
data-ad-slot="5328481604"
data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><main class="content" id="genesis-content"><article class="post-8733 post type-post status-publish format-standard has-post-thumbnail category-chrome category-news entry" itemscope itemtype="https://schema.org/CreativeWork"><div class="featured-image"><img src="https://chromeunboxed.com/wp-content/uploads/2019/05/chromeTextFromImage.jpg" alt="Pull Text Right From Photos With Crazy New Feature Coming To Chrome"/></div><header class="entry-header"><h1 class="entry-title" itemprop="headline">Pull Text Right From Photos With Crazy New Feature Coming To Chrome</h1>
<img alt='' src='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96'/><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-05-20T17:50:11-04:00">May 20, 2019</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://chromeunboxed.com/author/robbypayne/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Robby Payne</span></a></span> <span class="entry-comments-link"><a href="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/#respond"><span class="dsq-postid" data-dsqidentifier="8733 https://chromeunboxed.com/?p=8733">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-medium" id="share-before-8733"><div class="googlePlus" id="googleplus-before-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div><p><strong>Mark this one down as super-experimental but insanely cool, too. </strong> Chrome (and by extension, Chrome OS and Chromebooks) is always in development, always moving forward, and always up to new tricks that we never really thought possible with the web platform.  With the nature of the open-source Chromium project, however, all it takes is a bit of <a href="https://paul.kinlan.me/extracting-text-from-an-imageexperiments-with-shape-detection/" target="_blank" rel="noreferrer noopener" aria-label="an itch from a talented developer (opens in a new tab)">an itch from a talented developer</a> and we get a new feature in Chrome.</p>
<span id="more-8733"></span>
<p><strong>Debuting in Chrome 76, Chrome for Windows and Android (for now)</strong> now have the ability to scrape text directly from images using a combo of the same tech that drives the bar code detector, face detector, and text detector in Chrome.  Using these technologies, Chrome is able to actually scan and detect text on an image, pull it out, and then feed it back in a plain text format.</p>
<p>We’ve talked a bit about <a rel="noreferrer noopener" aria-label="Google Lens' ability (opens in a new tab)" href="https://chromeunboxed.com/news/google-lens-chromebook-grab-text-from-images/" target="_blank">Google Lens’ ability</a> to do this same thing in the app, but we’ve not had this available as a core part of the Chrome browser up until now.  <strong>The addition of this tech could lead to better accessibility features and searchable images in the future, never mind the ease of pulling text right off of a photo you come across online.</strong></p><div class="chrom-content innerAds" style="text-align: center;" id="chrom-748902391">
<div id="ezoic-pub-ad-placeholder-127">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><p>If you want to give it a go, keep in mind that this entire test is just that: <strong>a testing bed for this API. </strong> It works and the functionality is baked into Chrome 76 (you can try this test on Stable channel and the API won’t work in the following demo, for instance), but the execution of this feature isn’t really implemented just yet.  Paul Kinlan, the developer responsible for this addition, has created a testing site to show you the API in action, so <strong>you’ll need to test things there for now.</strong></p>
<p><strong>Here’s how to try it out:</strong></p>
<ul><li>Download &amp; install Chrome Canary for Android or Windows</li><li>Navigate to <strong>chrome://flags</strong></li><li>Search for ‘Experimental Web Platform Features’</li><li>Enable it and restart Chrome</li><li>Go to <a rel="noreferrer noopener" aria-label="￼http://copy-image-text.glitch.me (opens in a new tab)" href="http://copy-image-text.glitch.me/" target="_blank"></a><a href="http://copy-image-text.glitch.me/"></a><a href="http://copy-image-text.glitch.me/">http://copy-image-text.glitch.me/</a></li><li>Upload an image that has text on it</li><li>Submit and view the resulting scraped text</li></ul><p><strong>That’s really it. </strong> As I said, the execution is raw at this point, but this demo shows what this new feature is capable of.  With this info being able to be passed from a standard image over to a website or web app, it is now up to developers to get creative on how and where they will implement this.  I think the clearest example would be situations where text is trapped in an image and you simply need to copy it.  <strong>We’ve all been there and been frustrated by it.  Soon, it won’t be quite as big of a deal.</strong></p><div class="chrom-content-1 innerAds" style="text-align: center;" id="chrom-121633679">
<div id="ezoic-pub-ad-placeholder-126">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3946689793100734" data-ad-slot="5328481604" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="share-after share-filled share-medium" id="share-after-8733"><div class="googlePlus" id="googleplus-after-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-after-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-after-8733" data-url="https://chromeunboxed.com/chrome-76-text-from-photos-android-windows/" data-urlalt="https://wp.me/p7B4B8-2gR" data-text="Pull Text Right From Photos With Crazy New Feature Coming To Chrome" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div></div><div id="jp-relatedposts" class="jp-relatedposts"></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://chromeunboxed.com/chrome/" rel="category tag">Chrome</a>, <a href="https://chromeunboxed.com/news/" rel="category tag">News</a></span> </p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=160&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/096758db734ca07660c822eba9e7f61a?s=320&#038;d=mm&#038;r=g 2x' class='avatar avatar-160 photo' height='160' width='160'/><h4 class="author-box-title">About <span itemprop="name">Robby Payne</span></h4><div class="author-box-content" itemprop="description"><p>Tech junkie. Musician. Web Developer. Coffee Snob. Huge fan of the Google things. Founded Chrome Unboxed because so many of my passions collide in this space. I like that. I want to share that. I hope you enjoy it too.</p></div></section>
<div id="disqus_thread"></div></main></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p class="socialLinks"><a href="https://twitter.com/chromeunboxed" target="_blank">TWITTER</a> | <a href="https://www.facebook.com/Chromeunboxed/" target="_blank">FACEBOOK</a> | <a href="https://instagram.com/chromeunboxed/" target="_blank">INSTAGRAM</a> | <a href="https://mewe.com/page/5c6478173aebe52b522eccea" target="_blank">MEWE</a> | <a href="http://www.youtube.com/channel/UCkHgegL2XiXSlwY5zeCKKyg" target="_blank">YOUTUBE</a> | <a href="mailto:info@chromeunboxed.com" target="_blank">EMAIL</a></p> <div class="divider"></div><p>Copyright &#x000A9;&nbsp;2019 · Chrome Unboxed · <a href="http://google.com">Chrome is a registered trademark of Google Inc.</a><br><em>We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.</em></p>
<p><a href="/newsletter-sign-up/" class="footerButton">GET EMAIL UPDATES</a></p>
<p><a class="footerButton" href="https://g.ezoic.net/privacy/chromeunboxed.com" target="_blank">Privacy Policy</a></p><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav-2" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-864"><a href="https://chromeunboxed.com/reviews/" itemprop="url"><span itemprop="name">Reviews</span></a></li> <li id="menu-item-287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287"><a href="https://chromeunboxed.com/editorial/" itemprop="url"><span itemprop="name">Editorial</span></a></li> <li id="menu-item-285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-285"><a href="https://chromeunboxed.com/about/" itemprop="url"><span itemprop="name">About</span></a></li> </ul></div></nav></div></footer></div><style id="hustle-module-styles">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</style>
<script id="wpmudev-hustle-modal-with-optin-tpl" type="text/template">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</script>
<script id="wpmudev-hustle-modal-without-optin-tpl" type="text/template">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</script>
<script id="hustle-sshare-front-tpl" type="text/template">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</script>
<link rel="stylesheet" type="text/css" href="//chromeunboxed.com/wp-content/cache/wpfc-minified/oxwg8eu/6it5h.css" media="all"/>
<script data-wpfc-render="false">window.advads_has_ads=[["5763","ad",null],["5650","ad",null],["5651","ad",null]];
(window.advanced_ads_ready||jQuery(document).ready).call(null, function(){if(window.advanced_ads_pro){advanced_ads_pro.process_passive_cb();}else if(window.console&&window.console.log){console.log('Advanced Ads Pro: cache-busting can not be initialized');}});</script>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='hstl-roboto-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300i%2C400%2C400i%2C700%2C700i%7CRoboto%3A300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i&#038;ver=3.0.8.1' type='text/css' media='all'/>
<link rel='stylesheet' id='hstl-opensans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C400i%2C700%2C700i&#038;ver=3.0.8.1' type='text/css' media='all'/>
<link rel='stylesheet' id='hstl-source-code-pro-css' href='https://fonts.googleapis.com/css?family=Source+Code+Pro&#038;ver=3.0.8.1' type='text/css' media='all'/>
</noscript>
<script>var related_posts_js_options={"post_heading":"h4"};</script>
<script>var advanced_ads_pro_visitor_conditions={"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};</script>
<script>var advanced_ads_pro_ajax_object={"ajax_url":"https:\/\/chromeunboxed.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]}};</script>
<script>var countVars={"disqusShortname":"chrome-unboxed"};</script>
<script>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"8733 https:\/\/chromeunboxed.com\/?p=8733","disqusShortname":"chrome-unboxed","disqusTitle":"Pull Text Right From Photos With Crazy New Feature Coming To Chrome","disqusUrl":"https:\/\/chromeunboxed.com\/chrome-76-text-from-photos-android-windows\/","postId":"8733"};</script>
<script>var NoSidebarL10n={"mainMenu":"Menu","subMenu":"Menu"};</script>
<script async defer type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201921'></script>
<script src='//chromeunboxed.com/wp-content/cache/wpfc-minified/q7vhfiwc/6it5y.js' type="text/javascript"></script>
<!--[if lt IE 9]><script type='text/javascript' src='//chromeunboxed.com/wp-content/cache/wpfc-minified/jo97xv9w/6it5i.js'></script><![endif]-->
<script src='//chromeunboxed.com/wp-content/cache/wpfc-minified/md0eguvb/6it5i.js' type="text/javascript"></script>
<script type="text/javascript" src="https://s.skimresources.com/js/128737X1590626.skimlinks.js"></script>
<script src='//chromeunboxed.com/wp-content/cache/wpfc-minified/deb1d589/6it5y.js' type="text/javascript"></script>
<script type='text/javascript'>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</script>
<script defer src='//chromeunboxed.com/wp-content/cache/wpfc-minified/lkedqccd/6it6j.js' type="text/javascript"></script>
<script defer type='text/javascript' src='https://stats.wp.com/e-201921.js' async='async' defer='defer'></script>
<script>_stq=window._stq||[];
_stq.push([ 'view', {v:'ext',j:'1:7.3.1',blog:'112270166',post:'8733',tz:'-4',srv:'chromeunboxed.com'} ]);
_stq.push([ 'clickTrackerInit', '112270166', '8733' ]);</script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script>document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$('#googleplus-before-8733').sharrre({
share: {
googlePlus: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
buttons: {  },
click: function(api, options){
api.simulateClick();
api.openPopup('googlePlus');
}});
$('#facebook-before-8733').sharrre({
share: {
facebook: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
disableCount: true,
buttons: {  },
click: function(api, options){
api.simulateClick();
api.openPopup('facebook');
}});
$('#twitter-before-8733').sharrre({
share: {
twitter: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
buttons: {  twitter: { via: 'chromeunboxed' }},
click: function(api, options){
api.simulateClick();
api.openPopup('twitter');
}});
});});</script>
<script>document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$('#googleplus-after-8733').sharrre({
share: {
googlePlus: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
buttons: {  },
click: function(api, options){
api.simulateClick();
api.openPopup('googlePlus');
}});
$('#facebook-after-8733').sharrre({
share: {
facebook: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
disableCount: true,
buttons: {  },
click: function(api, options){
api.simulateClick();
api.openPopup('facebook');
}});
$('#twitter-after-8733').sharrre({
share: {
twitter: true
},
urlCurl: 'https://chromeunboxed.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
enableHover: false,
enableTracking: true,
buttons: {  twitter: { via: 'chromeunboxed' }},
click: function(api, options){
api.simulateClick();
api.openPopup('twitter');
}});
});});</script>
<script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/chromeunboxed.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=5&shcb=31', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=5&shcb=31', false, [], true, false, false, false);
</script>
</body></html><!-- WP Fastest Cache file was created in 0.75266408920288 seconds, on 20-05-19 18:17:12 --><!-- need to refresh to see cached version -->